aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hugo
diff options
context:
space:
mode:
authorThomas Boerger <thomas@webhippie.de>2016-12-20 09:56:11 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-12-20 14:54:46 +0100
commit38bb92c08b1d9ceb9a69e33e82c0a2f420e4c705 (patch)
tree6828082b067025b9185cbdf3f5252325f267568c /testing/hugo
parentc7d7a728310bb24da0dd65417d217487d4a53972 (diff)
downloadaports-38bb92c08b1d9ceb9a69e33e82c0a2f420e4c705.tar.bz2
aports-38bb92c08b1d9ceb9a69e33e82c0a2f420e4c705.tar.xz
testing/hugo: upgrade to 0.18
Beside the update I have also applied the common practice like dropping depends_dev and subpackages
Diffstat (limited to 'testing/hugo')
-rw-r--r--testing/hugo/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/testing/hugo/APKBUILD b/testing/hugo/APKBUILD
index 907fc00ec2..2600a76421 100644
--- a/testing/hugo/APKBUILD
+++ b/testing/hugo/APKBUILD
@@ -1,17 +1,15 @@
# Contributor: Thomas Boerger <thomas@webhippie.de>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=hugo
-pkgver=0.17
+pkgver=0.18
pkgrel=0
pkgdesc="A Fast and Flexible Static Site Generator built with love in GoLang"
url="http://gohugo.io/"
arch="all"
license="Apache 2.0"
depends=""
-depends_dev=""
-makedepends="$depends_dev go govendor"
+makedepends="go govendor"
install=""
-subpackages=""
source="${pkgname}-${pkgver}.tar.gz::https://github.com/spf13/hugo/archive/v$pkgver.tar.gz"
builddir="$srcdir/src/github.com/spf13/$pkgname"
@@ -25,13 +23,13 @@ build() {
cd "$builddir"
export GOPATH="$srcdir"
govendor sync || return 1
- go build
+ go build -v -o bin/$pkgname || return 1
}
package() {
- install -Dm755 "$builddir"/hugo "$pkgdir"/usr/bin/hugo
+ install -Dm755 "$builddir"/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
}
-md5sums="6e2b1c6b1eeac2cadda53a34caf5d9d6 hugo-0.17.tar.gz"
-sha256sums="c09913e00d8af9d7ffc7a6aa414c147f8edd7417d430fd59478989e544347590 hugo-0.17.tar.gz"
-sha512sums="1c21b029895182be2648fa4f4f3a8040a44f3d7db13fff378992b7eec23cd58ca4354358defbb317e679c1b2f176c1e4f0812b737404abc36f7f739ba3da0844 hugo-0.17.tar.gz"
+md5sums="f8b829b348ab7ea85c467631c6552fb0 hugo-0.18.tar.gz"
+sha256sums="9d432f53018d642526a44f9182b6584a4be83810dcd6ebc13e7a44c015ae35a0 hugo-0.18.tar.gz"
+sha512sums="b55a9e75a9d71fab2882d1eb923861dad0f504b219bcd9c6d5dd8a81fdb7509355cbb2ce692a488dc8b7439166772cd40563742234182e5e66c320906145583f hugo-0.18.tar.gz"