aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hwids
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-25 15:07:57 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-25 15:09:50 +0200
commit107990a8c66b184eb8c116f2697fc76627e8b722 (patch)
tree954b1247cfabd198203c6c63af4a76e178726df4 /testing/hwids
parent34218ed5e2a8b213a6a4bccf346a9bd586523c0d (diff)
downloadaports-107990a8c66b184eb8c116f2697fc76627e8b722.tar.bz2
aports-107990a8c66b184eb8c116f2697fc76627e8b722.tar.xz
testing/hwids: new aport
Hardware identification databases https://github.com/gentoo/hwids/ Copied from Adelie Linux
Diffstat (limited to 'testing/hwids')
-rw-r--r--testing/hwids/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/testing/hwids/APKBUILD b/testing/hwids/APKBUILD
new file mode 100644
index 0000000000..92b91d4cb3
--- /dev/null
+++ b/testing/hwids/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hwids
+pkgver=20190316
+pkgrel=0
+pkgdesc="Hardware identification databases"
+url="https://github.com/gentoo/hwids/"
+arch="noarch"
+options="!check" # No test suite, just databases.
+license="BSD-3-Clause OR GPL-2.0-or-later"
+makedepends="eudev-dev"
+subpackages="$pkgname-net $pkgname-pci $pkgname-udev $pkgname-usb"
+depends="$subpackages"
+subpackages="$subpackages $pkgname-doc"
+source="https://github.com/gentoo/hwids/archive/hwids-$pkgver.tar.gz"
+builddir="$srcdir/hwids-hwids-$pkgver"
+
+build() {
+ cd "$builddir"
+ make UDEV=yes
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" DOCDIR="/usr/share/doc/$pkgname-$pkgver" \
+ MISCDIR="/usr/share/hwdata" UDEV=yes install
+}
+
+_mv() {
+ local _file
+ pkgdesc="$pkgdesc ($1)"
+ shift
+ depends=""
+ mkdir -p "$subpkgdir"/usr/share/hwdata
+ for _file in $*; do
+ mv "$pkgdir"/usr/share/hwdata/$_file "$subpkgdir"/usr/share/hwdata
+ done
+}
+
+usb() {
+ replaces="hwdata-usb"
+ provides="hwdata-usb=$pkgver-r$pkgrel"
+ _mv "USB IDs" usb.ids
+}
+
+pci() {
+ replaces="hwdata-pci"
+ provides="hwdata-pci=$pkgver-r$pkgrel"
+ _mv "PCI IDs" pci.ids
+}
+
+net() {
+ replaces="hwdata-oui"
+ provides="hwdata-oui=$pkgver-r$pkgrel"
+ license="Public-Domain"
+ _mv "Networking OUIs" oui.txt iab.txt
+}
+
+udev() {
+ install_if="hwids=$pkgver-r$pkgrel eudev"
+ install_if="hwids-pci=$pkgver-r$pkgrel eudev"
+ install_if="hwids-usb=$pkgver-r$pkgrel eudev"
+ pkgdesc="$pkgdesc (udev integration)"
+
+ mkdir -p "$subpkgdir"/
+ mv "$pkgdir"/lib "$subpkgdir"/
+ mv "$pkgdir"/etc "$subpkgdir"/
+}
+
+sha512sums="6db50577b5d29d73f1dc0a44d0b74320cb0df186b9850160b15a6e8f2bcbdbf8193bae4146f81a5afc6b0e05706b5286b4b5858eb028d6c58ea4582df61d232e hwids-20190316.tar.gz"