aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hwloc
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-01-10 13:08:34 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-01-10 13:08:34 +0000
commit82324a1c63a22d190b445c16a65c7955fb507944 (patch)
tree38bd6a12e2250d4412c9a8238b5dab6ef88318d8 /testing/hwloc
parent913da2131472fb6b7e239cb4b0e8a3f9ecefd67e (diff)
downloadaports-82324a1c63a22d190b445c16a65c7955fb507944.tar.bz2
aports-82324a1c63a22d190b445c16a65c7955fb507944.tar.xz
testing/hwloc: attempt to allow build on armv7
Diffstat (limited to 'testing/hwloc')
-rw-r--r--testing/hwloc/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/hwloc/APKBUILD b/testing/hwloc/APKBUILD
index 59e883760d..5869511650 100644
--- a/testing/hwloc/APKBUILD
+++ b/testing/hwloc/APKBUILD
@@ -7,9 +7,10 @@ url="https://www.open-mpi.org/"
arch="all"
license="BSD-3-Clause"
makedepends="cairo-dev eudev-dev libxml2-dev ncurses-dev"
-if [ "$CARCH" != "armhf" ]; then
- makedepends="$makedepends numactl-dev"
-fi
+case "$CARCH" in
+ arm*) true;;
+ *) makedepends="$makedepends numactl-dev";;
+esac
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools:_tools"
source="https://www.open-mpi.org/software/hwloc/v${pkgver%.*}/downloads/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"