aboutsummaryrefslogtreecommitdiffstats
path: root/testing/i2pd
diff options
context:
space:
mode:
authoropal hart <opal@wowana.me>2018-10-31 06:47:33 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-01 15:29:26 +0000
commit262b38de90060adb6cd3601ae7184d6551473912 (patch)
treedebc73ab976e42cd0548cf3204cbe658ef683987 /testing/i2pd
parent53c40f97a7885b8daa780524ab5cd1c5872b9656 (diff)
downloadaports-262b38de90060adb6cd3601ae7184d6551473912.tar.bz2
aports-262b38de90060adb6cd3601ae7184d6551473912.tar.xz
testing/i2pd: Allow for use with syslog
Currently the init script for i2pd expects I2PD_LOG to be set and proceeds to touch the file on service start. However, i2pd is allowed to log to stdout/syslog which does not require this log file to be created. This patch removes the mandation that I2PD_LOG be set in /etc/conf.d/i2pd and will only touch the file if the log variable is set. For anyone using the default log-to-file settings, there is no noticeable change in functionality.
Diffstat (limited to 'testing/i2pd')
-rw-r--r--testing/i2pd/APKBUILD4
-rw-r--r--testing/i2pd/i2pd.initd7
2 files changed, 6 insertions, 5 deletions
diff --git a/testing/i2pd/APKBUILD b/testing/i2pd/APKBUILD
index 3287151525..c0dbc6f109 100644
--- a/testing/i2pd/APKBUILD
+++ b/testing/i2pd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: l-n-s <supervillain@riseup.net>
pkgname=i2pd
pkgver=2.21.1
-pkgrel=0
+pkgrel=1
pkgdesc="I2P Router written in C++"
url="https://github.com/PurpleI2P/i2pd"
arch="all !aarch64" # build fails on aarch64
@@ -47,5 +47,5 @@ package() {
}
sha512sums="e73c0c1f624b468a4a30996de77b27f5a2166d16b57724ec58647e5630f9e988052b11962fa47f318403ccd4c675a8d7c8b0ddcaa79666cea9743a6437fc4fd2 i2pd-2.21.1.tar.gz
-7911b5e06492ea25c90780a25e5d02f957c655153f41dd89c1f1885fb52ccdaf7c2e643ca3cd2f7d769a1d8c6d1790fcd4f8737abd21eed808940e1997ae6cb4 i2pd.initd
+5a95beef635fc2f5beecee314964fd41713ed61f92c4e972276208e0a2c86604c2b42a8e922863fc658a7a5789c9f43fddf7f76350fc281a44f2f42258a01201 i2pd.initd
ba94e5505f4eeb9a32159aa0a3b7f68ff077abb9704800f70502ac75fd5bcfcb20450ebd983d0523beca2d13e718d7bf888f53ec455d1f41701c16d09c3b2d28 i2pd.confd"
diff --git a/testing/i2pd/i2pd.initd b/testing/i2pd/i2pd.initd
index 16459ecd85..5f4346aba9 100644
--- a/testing/i2pd/i2pd.initd
+++ b/testing/i2pd/i2pd.initd
@@ -30,13 +30,14 @@ start_pre() {
if [ -z "${I2PD_USER}" ] || \
[ -z "${I2PD_GROUP}" ] || \
[ -z "${I2PD_PID}" ] || \
- [ -z "${I2PD_LOG}" ] || \
[ -z "${I2PD_OPTIONS}" ] ; then
- eerror "Not all variables I2PD_USER, I2PD_GROUP, I2PD_PID, I2PD_OPTIONS, I2PD_LOG are defined."
+ eerror "Not all variables I2PD_USER, I2PD_GROUP, I2PD_PID, I2PD_OPTIONS are defined."
eerror "Check your /etc/conf.d/i2pd."
return 1
fi
- checkpath -f -o "${user}" "${I2PD_LOG}"
+ if [ -n "${I2PD_LOG}" ]; then
+ checkpath -f -o "${user}" "${I2PD_LOG}"
+ fi
checkpath -d -m 0750 -o "${user}" "${I2PD_PID_DIR}"
}