aboutsummaryrefslogtreecommitdiffstats
path: root/testing/i2util/APKBUILD
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-01-06 21:42:35 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-01-22 14:13:46 +0000
commit073aaff70d0826ad419e78b14747c07cfa9e2a7a (patch)
treea74415ae4372560fd8f124473fbd1d04f6218421 /testing/i2util/APKBUILD
parentdbbdab5b084980b64b7713d792e4e128f23bcae8 (diff)
downloadaports-073aaff70d0826ad419e78b14747c07cfa9e2a7a.tar.bz2
aports-073aaff70d0826ad419e78b14747c07cfa9e2a7a.tar.xz
testing/i2util: new aport
Diffstat (limited to 'testing/i2util/APKBUILD')
-rw-r--r--testing/i2util/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/i2util/APKBUILD b/testing/i2util/APKBUILD
new file mode 100644
index 0000000000..61f685342f
--- /dev/null
+++ b/testing/i2util/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Ariadne Conill <ariadne@dereferenced.org>
+# Maintainer: Ariadne Conill <ariadne@dereferenced.org>
+pkgname="i2util"
+pkgver="4.2.1"
+pkgrel=0
+pkgdesc="Internet2 utility library"
+url="https://github.com/perfsonar/i2util"
+arch="all"
+license="Apache-2.0"
+depends=""
+depends_dev=""
+makedepends="$depends_dev autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/perfsonar/i2util/archive/v$pkgver/i2util-$pkgver.tar.gz"
+builddir="$srcdir/i2util-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ sh bootstrap.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="743ce52fb47637e1a6fafd00b00f0905007e5dd917325d946f6a4a6991eb4f711b883a05f1b79f1ea222146797df05cc779163f5cfd672c5a287cdea6de7cb1c i2util-4.2.1.tar.gz"