aboutsummaryrefslogtreecommitdiffstats
path: root/testing/i3wm-gaps
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-02-19 11:42:13 +0200
committerprspkt <prspkt@protonmail.com>2019-02-19 22:54:05 +0200
commit8deb82efbf9761378938e1da28fa15920f21b2ca (patch)
tree5db2690981b6ba4ccdebca961e158c477f970439 /testing/i3wm-gaps
parent08aa0ef4000ceedfb3e06395396a3eeaf39f52a3 (diff)
downloadaports-8deb82efbf9761378938e1da28fa15920f21b2ca.tar.bz2
aports-8deb82efbf9761378938e1da28fa15920f21b2ca.tar.xz
testing/i3wm-gaps: upgrade to 4.16.1
Diffstat (limited to 'testing/i3wm-gaps')
-rw-r--r--testing/i3wm-gaps/APKBUILD6
-rw-r--r--testing/i3wm-gaps/i3wm-musl-glob-tilde.patch30
2 files changed, 17 insertions, 19 deletions
diff --git a/testing/i3wm-gaps/APKBUILD b/testing/i3wm-gaps/APKBUILD
index ef5a80089c..0121a18e59 100644
--- a/testing/i3wm-gaps/APKBUILD
+++ b/testing/i3wm-gaps/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=i3wm-gaps
-pkgver=4.15.0.1
+pkgver=4.16.1
pkgrel=0
pkgdesc="Improved dynamic tiling window manager with additional features"
url="https://github.com/Airblader/i3"
@@ -40,5 +40,5 @@ package() {
install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/
}
-sha512sums="76ff860e4ca0edd0e22bdff9ae9b1bc150df2b5bc15b0d7ea7a63d373e8d156a43bd91f8a40c48b4c771603f7de7c18c6d16c53fef582e53f51c53a197fa7a0a i3wm-4.15.0.1.tar.gz
-8ce7d00371c43b93dabbe0dadf9caf7c58a68f4a0079f5a9b9552c15c55bfa0df16d7e87a281595af2ac5254632ba28ccf82a467cea16159b41490f6f2910299 i3wm-musl-glob-tilde.patch"
+sha512sums="904c2f63c6a35573f13fd216625c1349ac71de70ae8f0440667c9d76048cdaf30a398ab358f2366d5f46502d87e801713b625cb509a05f39dbca1371d2b8d0e9 i3wm-4.16.1.tar.gz
+c6ae3f22d0303da5de7ca4c92734b043a76d7447559fe2ffc308a8d135076cf05ee53ef63eb28c1bd628a1edfb2d1a0ed2d090836cb5fc70f2b882ee1105dad3 i3wm-musl-glob-tilde.patch"
diff --git a/testing/i3wm-gaps/i3wm-musl-glob-tilde.patch b/testing/i3wm-gaps/i3wm-musl-glob-tilde.patch
index 82ad6195b8..d4f9113e6b 100644
--- a/testing/i3wm-gaps/i3wm-musl-glob-tilde.patch
+++ b/testing/i3wm-gaps/i3wm-musl-glob-tilde.patch
@@ -1,10 +1,9 @@
-diff -urp i3-4.11/i3bar/src/main.c i3-4.11.new/i3bar/src/main.c
---- i3-4.11/i3bar/src/main.c 2015-09-30 07:55:10.000000000 +0100
-+++ i3-4.11.new/i3bar/src/main.c 2016-02-08 20:03:41.777392482 +0000
-@@ -45,14 +45,20 @@ void debuglog(char *fmt, ...) {
+--- a/i3bar/src/main.c
++++ b/i3bar/src/main.c
+@@ -48,14 +48,20 @@ void debuglog(char *fmt, ...) {
*
*/
- char *expand_path(char *path) {
+ static char *expand_path(char *path) {
- static glob_t globbuf;
- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
- ELOG("glob() failed\n");
@@ -27,19 +26,18 @@ diff -urp i3-4.11/i3bar/src/main.c i3-4.11.new/i3bar/src/main.c
+
+ return sstrdup(path);
}
-
+
void print_usage(char *elf_name) {
-diff -urp i3-4.11/libi3/resolve_tilde.c i3-4.11.new/libi3/resolve_tilde.c
---- i3-4.11/libi3/resolve_tilde.c 2015-09-30 07:55:10.000000000 +0100
-+++ i3-4.11.new/libi3/resolve_tilde.c 2016-02-08 20:03:47.849230953 +0000
-@@ -19,27 +19,18 @@
+--- a/libi3/resolve_tilde.c
++++ b/libi3/resolve_tilde.c
+@@ -19,28 +19,18 @@
*
*/
char *resolve_tilde(const char *path) {
- static glob_t globbuf;
- char *head, *tail, *result;
+ char *home, *expanded;
-
+
- tail = strchr(path, '/');
- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
-
@@ -53,9 +51,9 @@ diff -urp i3-4.11/libi3/resolve_tilde.c i3-4.11.new/libi3/resolve_tilde.c
- } else {
- head = globbuf.gl_pathv[0];
- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
-- strncpy(result, head, strlen(head));
-- if (tail)
-- strncat(result, tail, strlen(tail));
+- strcpy(result, head);
+- if (tail) {
+- strcat(result, tail);
+ if (strncmp(path, "~/", 2) == 0) {
+ home = getenv("HOME");
+ if (home != NULL) {
@@ -64,10 +62,10 @@ diff -urp i3-4.11/libi3/resolve_tilde.c i3-4.11.new/libi3/resolve_tilde.c
+ strcpy(expanded, home);
+ strcat(expanded, path+1);
+ return expanded;
-+ }
+ }
}
- globfree(&globbuf);
-
+
- return result;
+ return sstrdup(path);
}