aboutsummaryrefslogtreecommitdiffstats
path: root/testing/i3wm-gaps
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-27 16:26:51 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-27 16:26:51 +0100
commit9e88684d8498778006110dbaab356e0c56870ca2 (patch)
tree14eaf2a2286f6e934852aef6edca2840ee98d83b /testing/i3wm-gaps
parent7220f6229601216b49f560012151b6c59b0a653f (diff)
downloadaports-9e88684d8498778006110dbaab356e0c56870ca2.tar.bz2
aports-9e88684d8498778006110dbaab356e0c56870ca2.tar.xz
testing/i3wm-gaps: remove obsolete patch
Diffstat (limited to 'testing/i3wm-gaps')
-rw-r--r--testing/i3wm-gaps/APKBUILD3
-rw-r--r--testing/i3wm-gaps/i3wm-musl-glob-tilde.patch71
2 files changed, 1 insertions, 73 deletions
diff --git a/testing/i3wm-gaps/APKBUILD b/testing/i3wm-gaps/APKBUILD
index d8e1a8b972..f0579c98c6 100644
--- a/testing/i3wm-gaps/APKBUILD
+++ b/testing/i3wm-gaps/APKBUILD
@@ -12,8 +12,7 @@ makedepends="bison flex libxcb-dev xcb-util-cursor-dev
yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev
xcb-util-xrm-dev asciidoc perl xmlto autoconf automake libtool"
subpackages="$pkgname-doc"
-source="i3wm-$pkgver.tar.gz::https://github.com/Airblader/i3/archive/$pkgver.tar.gz
- "
+source="i3wm-$pkgver.tar.gz::https://github.com/Airblader/i3/archive/$pkgver.tar.gz"
builddir="$srcdir/i3-$pkgver"
options="!check" # missing perl bindings for libxcb
diff --git a/testing/i3wm-gaps/i3wm-musl-glob-tilde.patch b/testing/i3wm-gaps/i3wm-musl-glob-tilde.patch
deleted file mode 100644
index d4f9113e6b..0000000000
--- a/testing/i3wm-gaps/i3wm-musl-glob-tilde.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- a/i3bar/src/main.c
-+++ b/i3bar/src/main.c
-@@ -48,14 +48,20 @@ void debuglog(char *fmt, ...) {
- *
- */
- static char *expand_path(char *path) {
-- static glob_t globbuf;
-- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
-- ELOG("glob() failed\n");
-- exit(EXIT_FAILURE);
-+ char *home, *expanded;
-+
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
-+ }
- }
-- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
-- globfree(&globbuf);
-- return result;
-+
-+ return sstrdup(path);
- }
-
- void print_usage(char *elf_name) {
---- a/libi3/resolve_tilde.c
-+++ b/libi3/resolve_tilde.c
-@@ -19,28 +19,18 @@
- *
- */
- char *resolve_tilde(const char *path) {
-- static glob_t globbuf;
-- char *head, *tail, *result;
-+ char *home, *expanded;
-
-- tail = strchr(path, '/');
-- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
--
-- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
-- free(head);
-- /* no match, or many wildcard matches are bad */
-- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
-- result = sstrdup(path);
-- else if (res != 0) {
-- err(EXIT_FAILURE, "glob() failed");
-- } else {
-- head = globbuf.gl_pathv[0];
-- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
-- strcpy(result, head);
-- if (tail) {
-- strcat(result, tail);
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
- }
- }
-- globfree(&globbuf);
-
-- return result;
-+ return sstrdup(path);
- }