aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ibmswtpm2
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-10-09 21:04:18 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-12 22:17:09 +0000
commitad075be2138b9720aba6fe510b7ac6d505c3edb5 (patch)
tree4ee092d08361865ecf95f07a00f2448cea73634d /testing/ibmswtpm2
parent509f71bcdd13f4ad18c27bcb581127fe12ded835 (diff)
downloadaports-ad075be2138b9720aba6fe510b7ac6d505c3edb5.tar.bz2
aports-ad075be2138b9720aba6fe510b7ac6d505c3edb5.tar.xz
testing/ibmswtpm2: new aport
http://ibmswtpm.sourceforge.net/ibmswtpm2.html This project is a software implementation of the TCG TPM 2.0 specification. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Closes !324
Diffstat (limited to 'testing/ibmswtpm2')
-rw-r--r--testing/ibmswtpm2/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/ibmswtpm2/APKBUILD b/testing/ibmswtpm2/APKBUILD
new file mode 100644
index 0000000000..b3130e0340
--- /dev/null
+++ b/testing/ibmswtpm2/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Olliver Schinagl <oliver@schinagl.nl>
+# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
+pkgname="ibmswtpm2"
+pkgver="1332"
+pkgrel=0
+pkgdesc="Software implementation of the TCG TPM 2.0 specification by IBM."
+url="http://ibmswtpm.sourceforge.net/ibmswtpm2.html"
+arch="all"
+license="MIT"
+makedepends="musl-dev openssl-dev"
+options="!check" # No selftest available
+source="https://downloads.sourceforge.net/project/ibmswtpm2/ibmtpm${pkgver}.tar.gz"
+builddir="${srcdir}/src"
+
+build() {
+ make
+}
+
+package() {
+ install -D -m 655 -t "${pkgdir}/usr/bin" \
+ "${builddir}/tpm_server"
+}
+
+sha512sums="63ef597e9d958a0039b88f3f864f063546223641f8550869d21e401cd55464ccb6b3e8421354653acb9266a39b4417d930e3fe6f1825991931c2eadd4bf7b2a6 ibmtpm1332.tar.gz"