aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ibniz
diff options
context:
space:
mode:
authorJohannes Matheis <jomat+alpinebuild@jmt.gr>2015-02-22 06:23:12 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-02-23 08:00:01 +0000
commit7bc5e97911bdbfc3180312591c76ec63c94b08b8 (patch)
tree1688e61bef5ce45e7851c8d8c1778417b82e30e5 /testing/ibniz
parent840920fa28ef54c3caa08be40253e1c9b5169d3d (diff)
downloadaports-7bc5e97911bdbfc3180312591c76ec63c94b08b8.tar.bz2
aports-7bc5e97911bdbfc3180312591c76ec63c94b08b8.tar.xz
testing/ibniz: new aport
A virtual machine designed for extremely compact low-level audiovisual programs http://pelulamu.net/ibniz/ Signed-off-by: Leonardo Arena <rnalrd@alpinelinux.org>
Diffstat (limited to 'testing/ibniz')
-rw-r--r--testing/ibniz/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/ibniz/APKBUILD b/testing/ibniz/APKBUILD
new file mode 100644
index 0000000000..a1ef5ff7fe
--- /dev/null
+++ b/testing/ibniz/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+pkgname=ibniz
+pkgver=1.18
+pkgrel=0
+pkgdesc="A virtual machine designed for extremely compact low-level audiovisual programs"
+url="http://pelulamu.net/ibniz/"
+arch="all"
+license="zlib"
+depends=""
+depends_dev="sdl-dev"
+makedepends="$depends_dev"
+install=""
+source="${url}/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make
+
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 ibniz "$pkgdir/usr/bin/ibniz"
+ install -D -m644 licence.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}
+
+md5sums="81ee96b253111cfe2abdc7a843757287 ibniz-1.18.tar.gz"
+sha256sums="e2f292641a67abd477fac8f2c455fa1579ba854c1f15152a41fef48fd46c6481 ibniz-1.18.tar.gz"
+sha512sums="63448e3eb639a831b847cc3a737040a661ff4107e53ff70b9c33ba951c584ca903729547efd27afff9ac0b9e25a315a1d36670a4f4722c3d2287f375cb1bd760 ibniz-1.18.tar.gz"