aboutsummaryrefslogtreecommitdiffstats
path: root/testing/icingaweb2-module-businessprocess
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-02-08 15:35:29 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-02-08 15:35:34 +0000
commit6a809057966d326cd79647149699d2346b0047f7 (patch)
tree503d85537ee5772e6bf69bb71ae8ae68573d0901 /testing/icingaweb2-module-businessprocess
parenta19bf3643d32bba09143b1eb770bcebf89add1d6 (diff)
downloadaports-6a809057966d326cd79647149699d2346b0047f7.tar.bz2
aports-6a809057966d326cd79647149699d2346b0047f7.tar.xz
testing/icingaweb2-module-businessprocess: new aport
Diffstat (limited to 'testing/icingaweb2-module-businessprocess')
-rw-r--r--testing/icingaweb2-module-businessprocess/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/testing/icingaweb2-module-businessprocess/APKBUILD b/testing/icingaweb2-module-businessprocess/APKBUILD
new file mode 100644
index 0000000000..2789107ae7
--- /dev/null
+++ b/testing/icingaweb2-module-businessprocess/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=icingaweb2-module-businessprocess
+_module=${pkgname/*-/}
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Manage Business Processes in Icinga Web 2 "
+url="http://www.icinga.org"
+arch="noarch"
+license="GPL2"
+_php=php5
+depends="icingaweb2-module-director"
+pkggroups="icingaweb2"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ mkdir -p "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ cp -a application library public \
+ module.info run.php configuration.php \
+ "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ cp -a doc "$pkgdir/usr/share/doc/$pkgname"
+ chgrp -R $pkggroups "$pkgdir/etc/icingaweb2/modules/$_module"
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+You need to fix /etc/icingaweb2/modules/$_module with the owner of the user of your webserver
+
+For nginx, as example:
+ # chown -R nginx /etc/icingaweb2/modules/$_module
+or
+ # chown -R nobody /etc/icingaweb2/modules/$_module
+
+For Apache:
+ # chown -R apache /etc/icingaweb2/modules/$_module
+
+For lighttpd:
+ # chown -R lighttpd /etc/icingaweb2/modules/$_module
+
+
+Remember to enable the module with:
+
+ # icingacli $_module module enable $_module
+
+EOF
+
+}
+
+md5sums="1cc38ff801832469cad9da3b1ea8f29e icingaweb2-module-businessprocess-2.0.0.tar.gz"
+sha256sums="d1694b287bd58aa61992191cedf491e6b78217be225667be0c3cd638a5a5a775 icingaweb2-module-businessprocess-2.0.0.tar.gz"
+sha512sums="65642e4bff6019ba64ab188e101508b1ea14ba8c6e8c57bd08fc351ac64ca1c303263eb9ba9b1ee2a69106933af50af6882c3826d528552d3befb0373eff37b1 icingaweb2-module-businessprocess-2.0.0.tar.gz"