aboutsummaryrefslogtreecommitdiffstats
path: root/testing/icmake
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-11 07:13:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-11 07:17:12 -0300
commit843f9ee669b79dcb4774c5bb5858bf92184057fb (patch)
treed45bdbebc64364371176257127b2bc279ebaf829 /testing/icmake
parent7053fd8f5d4227c6aada01b9e6ed2f446b4f699b (diff)
downloadaports-843f9ee669b79dcb4774c5bb5858bf92184057fb.tar.bz2
aports-843f9ee669b79dcb4774c5bb5858bf92184057fb.tar.xz
testing/icmake: fix building of icmake-comp
Diffstat (limited to 'testing/icmake')
-rw-r--r--testing/icmake/APKBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/testing/icmake/APKBUILD b/testing/icmake/APKBUILD
index 0ec0f4348f..54935cf027 100644
--- a/testing/icmake/APKBUILD
+++ b/testing/icmake/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Shiz <hi@shiz.me>
pkgname=icmake
pkgver=9.02.08
-pkgrel=0
+pkgrel=1
pkgdesc="Make utility using a C-like grammar"
url="https://fbb-git.github.io/icmake/"
arch="all"
@@ -15,25 +15,17 @@ builddir="$srcdir/icmake-$pkgver/icmake"
prepare() {
default_prepare
- cd "$builddir"
sed -i '/^#define DOCDOCDIR/d' INSTALL.im
echo '#define DOCDOCDIR "usr/share/doc/icmake"' >> INSTALL.im
}
build() {
- cd "$builddir"
+ export CFLAGS="$CFLAGS -O2"
./icm_prepare /
./icm_bootstrap x
}
-check() {
- cd "$builddir"
- ./tmp/usr/bin/icmake --version
- ./tmp/usr/bin/icmbuild --version
-}
-
package() {
- cd "$builddir"
./icm_install strip all "$pkgdir"
}