aboutsummaryrefslogtreecommitdiffstats
path: root/testing/imapfilter/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-07 07:46:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:16 +0000
commitd2e4cecc82a64cf72ff60d2b8fd189aa61307712 (patch)
tree89809ada61dca074d605643514fa26f0a70862d6 /testing/imapfilter/APKBUILD
parent0225c0e1f5612c8875ff117e2eb41552805efcf1 (diff)
downloadaports-d2e4cecc82a64cf72ff60d2b8fd189aa61307712.tar.bz2
aports-d2e4cecc82a64cf72ff60d2b8fd189aa61307712.tar.xz
testing/imapfilter: upgrade to 2.6.12 and modernize
Diffstat (limited to 'testing/imapfilter/APKBUILD')
-rw-r--r--testing/imapfilter/APKBUILD43
1 files changed, 10 insertions, 33 deletions
diff --git a/testing/imapfilter/APKBUILD b/testing/imapfilter/APKBUILD
index f4cb9c6d72..a7a989b109 100644
--- a/testing/imapfilter/APKBUILD
+++ b/testing/imapfilter/APKBUILD
@@ -1,53 +1,30 @@
# Contributor: Andrew Hills <ahills@ednos.net>
# Maintainer: Andrew Hills <ahills@ednos.net>
pkgname=imapfilter
-pkgver=2.5.7
-pkgrel=5
+pkgver=2.6.12
+pkgrel=0
pkgdesc="Lua-based filtering for IMAP mailboxes"
url="https://github.com/lefcha/imapfilter"
arch="all"
license="MIT"
-depends=""
-depends_dev=
-makedepends="$depends_dev lua-dev libressl-dev pcre-dev libc-dev"
-install=
+makedepends="$depends_dev lua-dev openssl-dev pcre-dev libc-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/lefcha/$pkgname/archive/v${pkgver}.tar.gz
- io-flush.patch
- libressl.patch
"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$_builddir"
- make PREFIX=/usr all || return 1
+ make PREFIX=/usr all
}
package() {
cd "$_builddir"
make \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- DESTDIR="$pkgdir" \
- install
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="$pkgdir" \
+ install
}
-md5sums="5af01afcca4a24b46f113f36bc3eaef8 imapfilter-2.5.7.tar.gz
-c005e65cae202f8f6779380996d51ee1 io-flush.patch
-27ba5b28471fe3c401353d3a46b5caa3 libressl.patch"
-sha256sums="c792d6a3a187cdc14fc38470837b45722a3750dabd2c6f71672806eeef79fad0 imapfilter-2.5.7.tar.gz
-14c49fd8ced2a0730a0b21e20e5b2149ad3a65eca55e258d591fef3f06befb59 io-flush.patch
-c57570be4d854615d9b466af594c10bda6e2819640b197e7ae183838cfb362ff libressl.patch"
-sha512sums="9297e98812312fbf2c92aa5477bdfecb522048e45b4bc4922e312bd89a72b020a98f5547e3f0882ae665c24db21e6995eda839b762947adc48bc413ab0c882f1 imapfilter-2.5.7.tar.gz
-ab11ad7b52f0b56119e6da636bf4c53f09ca9f2fe8a7083fc9af9528ba0d67657b639283a3100868c919b3958c812ae7169d8879af4b7205f43207458e0b8073 io-flush.patch
-416614d44f64627f9e3dbbf0b11972618dde5129dbfd494289b63db491b8c9b8c1fee44112237af88ea42bd9a803c0b7a64de16d33b81d3d775b237bcc6a8626 libressl.patch"
+sha512sums="1425041c288ac46833af6119fd0169cf783a1fec61bf07dfad6f732ec74834ec3beb4e81c3b19f7436310324d9a4369c4ec61aa3a83eef203d7897ea0fc26528 imapfilter-2.6.12.tar.gz"