aboutsummaryrefslogtreecommitdiffstats
path: root/testing/img
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2019-02-08 22:31:11 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 14:19:40 +0000
commitb9e2e0c480ef3958c6dfac5191afb37a48cbec1a (patch)
tree50514ff1ca79f2cfd15bdc827e0bdf8931028389 /testing/img
parent99f2aaa0ed9c4482c2f4412c03f4bee3596cf953 (diff)
downloadaports-b9e2e0c480ef3958c6dfac5191afb37a48cbec1a.tar.bz2
aports-b9e2e0c480ef3958c6dfac5191afb37a48cbec1a.tar.xz
testing/img: new aport
https://github.com/genuinetools/img Standalone, daemon-less, unprivileged Dockerfile and OCI compatible container image builder
Diffstat (limited to 'testing/img')
-rw-r--r--testing/img/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/img/APKBUILD b/testing/img/APKBUILD
new file mode 100644
index 0000000000..0e187eb69a
--- /dev/null
+++ b/testing/img/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
+# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
+pkgname=img
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="Standalone, daemon-less, unprivileged Dockerfile and OCI compatible container image builder"
+url="https://github.com/genuinetools/img"
+arch="x86_64"
+license="MIT"
+options="!check"
+depends="go runc shadow-uidmap"
+makedepends="libseccomp-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/genuinetools/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/src/github.com/genuinetools/img"
+
+build() {
+ cd "$srcdir"
+ export GOPATH="$PWD"
+ mkdir -p $(dirname "$builddir")
+ ln -s "$PWD/$pkgname-$pkgver" "$builddir"
+ cd "$builddir"
+ go get -u github.com/jteeuwen/go-bindata/...
+ make BUILDTAGS="seccomp noembed"
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+}
+
+sha512sums="2a8115e738927715f30a41cb09da2176319d7beaa343ec3d59fc25f3bbc24ec2a215b8b2072c08d92ce853d0627eebd54c54a489e9aa8552a924e0f89dcc886e img-0.5.0.tar.gz"