aboutsummaryrefslogtreecommitdiffstats
path: root/testing/irccd
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-07 13:05:19 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-07 14:14:50 +0000
commitf52e791f66245a97b34cd7d01ae64c8dfb999c7f (patch)
treecbb157283ab6e1756d6789a5bfd9f5de96eb5635 /testing/irccd
parentc9e7fc5dad3552805d0619ddfd97adabdbe4977a (diff)
downloadaports-f52e791f66245a97b34cd7d01ae64c8dfb999c7f.tar.bz2
aports-f52e791f66245a97b34cd7d01ae64c8dfb999c7f.tar.xz
testing/irccd: new aport
http://projects.malikania.fr/irccd IRC Client Daemon
Diffstat (limited to 'testing/irccd')
-rw-r--r--testing/irccd/APKBUILD54
-rw-r--r--testing/irccd/irccd.confd2
-rw-r--r--testing/irccd/irccd.initd7
3 files changed, 63 insertions, 0 deletions
diff --git a/testing/irccd/APKBUILD b/testing/irccd/APKBUILD
new file mode 100644
index 0000000000..47fd43ab45
--- /dev/null
+++ b/testing/irccd/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=irccd
+pkgver=3.0.3
+pkgrel=0
+pkgdesc="IRC Client Daemon"
+url="http://projects.malikania.fr/irccd"
+arch="all"
+license="ISC"
+depends="boost-system"
+makedepends="boost-dev cmake doxygen libedit-dev openssl-dev uriparser-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://releases.malikania.fr/irccd/$pkgver/irccd-$pkgver.tar.xz
+ irccd.initd
+ irccd.confd"
+pkgusers="irccd"
+pkggroups="irccd"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DIRCCD_WITH_TESTS=On \
+ $CMAKE_CROSSOPTS .
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+
+ install -m644 -o "$pkgusers" -g "$pkggroups" \
+ "$pkgdir"/etc/irccd.conf.sample "$pkgdir"/etc/irccd.conf
+ install -m644 -o "$pkgusers" -g "$pkggroups" \
+ "$pkgdir"/etc/irccdctl.conf.sample "$pkgdir"/etc/irccdctl.conf
+
+ install -Dm755 "$srcdir"/irccd.initd "$pkgdir"/etc/init.d/irccd
+ install -Dm644 "$srcdir"/irccd.confd "$pkgdir"/etc/conf.d/irccd
+}
+
+sha512sums="13ec29bc01700263f853cc0e04ddc0b2c9d46a9216a1d9b327be5f0a38f9a089b10bb312f95da763c44f5014dd35ece5a6ecef58acae8ff81990de44ecc1acfc irccd-3.0.3.tar.xz
+0ae7907a9724a55e30eac5d19c6b1e5e83ddea6ee90a8a377030f521de9c28c9cec103fbce4fc097ac59f55b7048bc9dee395affd9300de3a79ac2e86d0c75d0 irccd.initd
+93ce8795790a21e87cdfb9d31737af73faa200244c448841cd65e52f0523e8f664151e61dbf431df8360473d73c3ca5b3b8b6bcb0ccec52f66e511ae9f2abbdb irccd.confd"
diff --git a/testing/irccd/irccd.confd b/testing/irccd/irccd.confd
new file mode 100644
index 0000000000..c53fe29411
--- /dev/null
+++ b/testing/irccd/irccd.confd
@@ -0,0 +1,2 @@
+# enter the irccd options
+IRCCD_OPTS="-c /etc/irccd.conf"
diff --git a/testing/irccd/irccd.initd b/testing/irccd/irccd.initd
new file mode 100644
index 0000000000..42158609c7
--- /dev/null
+++ b/testing/irccd/irccd.initd
@@ -0,0 +1,7 @@
+#!/sbin/openrc-run
+
+name="IRC Client Daemon"
+command="/usr/bin/irccd"
+command_args="$IRCCD_OPTS"
+pidfile="/var/run/irccd.pid"
+start_stop_daemon_args="-b -m -u irccd -g irccd"