aboutsummaryrefslogtreecommitdiffstats
path: root/testing/irrlicht
diff options
context:
space:
mode:
authorxming <xmingske@gmail.com>2014-09-21 12:38:05 +0000
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-09-21 14:43:24 +0200
commitaf5da010075617a30d42d7f84acdbdca6e835be4 (patch)
tree2c84c613416d6c21389c028b5bf5a11beb7b98a0 /testing/irrlicht
parent14253e00b6b6c62f2e2605097fc8a1f203b7da80 (diff)
downloadaports-af5da010075617a30d42d7f84acdbdca6e835be4.tar.bz2
aports-af5da010075617a30d42d7f84acdbdca6e835be4.tar.xz
testing/irrlicht: version bump to 1.8.1 + compile fixes
Diffstat (limited to 'testing/irrlicht')
-rw-r--r--testing/irrlicht/APKBUILD29
-rw-r--r--testing/irrlicht/irrlicht-1.8.1-config.patch29
-rw-r--r--testing/irrlicht/irrlicht-1.8.1-mesa-10.x.patch40
-rw-r--r--testing/irrlicht/irrlicht-1.8.1-sysctl.patch11
4 files changed, 101 insertions, 8 deletions
diff --git a/testing/irrlicht/APKBUILD b/testing/irrlicht/APKBUILD
index 4c95602d0c..0c8525cb63 100644
--- a/testing/irrlicht/APKBUILD
+++ b/testing/irrlicht/APKBUILD
@@ -1,26 +1,30 @@
# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
pkgname=irrlicht
-pkgver=1.8
+pkgver=1.8.1
case $pkgver in
*.*.*) _pkgmajver=${pkgver%.*};;
*.*) _pkgmajver=${pkgver};;
esac
-pkgrel=1
+pkgrel=0
pkgdesc="3D graphics engine"
url="http://irrlicht.sourceforge.net"
arch="all"
license="ZLIB"
depends=
-depends_dev="mesa-dev jpeg-dev bzip2 libpng-dev zlib-dev"
+depends_dev="musl-dev mesa-dev jpeg-dev bzip2 libpng-dev zlib-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://downloads.sourceforge.net/irrlicht/irrlicht-$pkgver.zip"
+source="http://downloads.sourceforge.net/irrlicht/irrlicht-$pkgver.zip
+ irrlicht-1.8.1-mesa-10.x.patch
+ irrlicht-1.8.1-config.patch
+ irrlicht-1.8.1-sysctl.patch
+"
_builddir="$srcdir"/$pkgname-$pkgver/source/Irrlicht
prepare() {
local i
- cd "$_builddir"
+ cd "$srcdir"/$pkgname-$pkgver/
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -78,6 +82,15 @@ package() {
install -m755 "$srcdir"/$pkgname-$pkgver/bin/Linux/* "$pkgdir"/usr/share/$pkgname/examples/bin/
}
-md5sums="d06329d8f466658caaf4838ba349e393 irrlicht-1.8.zip"
-sha256sums="f8756c3cf83f16f41eb1eca8f4ebb530f0e8fd572443905e3d8eb8f09445a642 irrlicht-1.8.zip"
-sha512sums="07aa6e49252f073e352fbd715b77d171b6d25d22e6b0faccaf7328b28693e6851f37498cfb4094f7b09d122170c491571431bf8f698828e82c2aa9d7ff792af7 irrlicht-1.8.zip"
+md5sums="f4f7fa33bd1060eb0dd51dcd66b0f6e3 irrlicht-1.8.1.zip
+b83f74be3507b9a0488ac15892456ac9 irrlicht-1.8.1-mesa-10.x.patch
+6d5005f9a88b678a4b8009da46069346 irrlicht-1.8.1-config.patch
+c3fff009069d5dcabfd97ba12d630554 irrlicht-1.8.1-sysctl.patch"
+sha256sums="814bb90116d5429449ba1d169e2cbff881c473b7eada4c2447132bc4f4a6e97b irrlicht-1.8.1.zip
+d17e8084cb5b458aef85a136b6366e07e615b8dcca18fd7f66a988886d7ab750 irrlicht-1.8.1-mesa-10.x.patch
+b7bc41b6864410fb7449c4bd61bbf5cb7a2de701cc755e56822b0b41b27595c9 irrlicht-1.8.1-config.patch
+2eee9b466bb54a551e573b2db47126669288e0671d0772489a2f0956430d4619 irrlicht-1.8.1-sysctl.patch"
+sha512sums="93390c162e5a8edb231588d47dc421c24d21a34e833df1f3b92c85a9e8ef4a96a61d854e05eedb37f88f7f02821059e78a40a52cbc8e39356c4d36b17775dfbb irrlicht-1.8.1.zip
+44c16419c07597ba6d06d66057fbe2ab86e7b02b5dcdf458678b4ea87f6f721840da951ae4df59c983e1da83abdbe45f82e44a6a311bd42eb94d93dfd5aa437c irrlicht-1.8.1-mesa-10.x.patch
+6ace3397f0593720abbb7884bf398aa8186c0d2f99f54012b1496052ef3645e17b21a3b81c141becf8424851f4f914ee912dcece4962824c633fa8e0ad65ba82 irrlicht-1.8.1-config.patch
+8488b8f00728ab54ffd7a60f8b5e95677323d47c3deb3ed2e492cbd8108c4df6cabc35881186aecd7c6db700f3925728849a7aaffede77b9ac93e98d424c5d9f irrlicht-1.8.1-sysctl.patch"
diff --git a/testing/irrlicht/irrlicht-1.8.1-config.patch b/testing/irrlicht/irrlicht-1.8.1-config.patch
new file mode 100644
index 0000000000..a394dc14d2
--- /dev/null
+++ b/testing/irrlicht/irrlicht-1.8.1-config.patch
@@ -0,0 +1,29 @@
+--- a/include/IrrCompileConfig.h
++++ b/include/IrrCompileConfig.h
+@@ -249,7 +249,7 @@
+ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
++//#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #undef _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #endif
+@@ -265,7 +265,7 @@
+ //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_LIB_PNG_
++//#define _IRR_USE_NON_SYSTEM_LIB_PNG_
+ #ifdef NO_IRR_USE_NON_SYSTEM_LIB_PNG_
+ #undef _IRR_USE_NON_SYSTEM_LIB_PNG_
+ #endif
+@@ -602,7 +602,7 @@
+ /** If this is commented out, Irrlicht will try to compile using the zlib
+ installed on the system. This is only used when _IRR_COMPILE_WITH_ZLIB_ is
+ defined. */
+-#define _IRR_USE_NON_SYSTEM_ZLIB_
++//#define _IRR_USE_NON_SYSTEM_ZLIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_ZLIB_
+ #undef _IRR_USE_NON_SYSTEM_ZLIB_
+ #endif
diff --git a/testing/irrlicht/irrlicht-1.8.1-mesa-10.x.patch b/testing/irrlicht/irrlicht-1.8.1-mesa-10.x.patch
new file mode 100644
index 0000000000..ab0b117c17
--- /dev/null
+++ b/testing/irrlicht/irrlicht-1.8.1-mesa-10.x.patch
@@ -0,0 +1,40 @@
+From 244d00280c1b082ca164f92337773e9e4e1a3898 Mon Sep 17 00:00:00 2001
+From: hiker <henrichsjoerg@mgail.com>
+Date: Wed, 26 Feb 2014 11:13:03 +1100
+Subject: [PATCH] Applied patch from jpirie for fixing mesa 10 compilation
+ problems.
+
+--- irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
++++ irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
+@@ -21,6 +21,7 @@
+ #endif
+ #include <GL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #include "wglext.h"
+@@ -35,6 +36,7 @@
+ #endif
+ #include <OpenGL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #elif defined(_IRR_COMPILE_WITH_SDL_DEVICE_) && !defined(_IRR_COMPILE_WITH_X11_DEVICE_)
+@@ -48,6 +50,7 @@
+ #define NO_SDL_GLEXT
+ #include <SDL/SDL_video.h>
+ #include <SDL/SDL_opengl.h>
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #else
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+@@ -60,6 +63,7 @@
+ #include <GL/gl.h>
+ #include <GL/glx.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #undef GLX_ARB_get_proc_address // avoid problems with local glxext.h
+ #include "glxext.h"
diff --git a/testing/irrlicht/irrlicht-1.8.1-sysctl.patch b/testing/irrlicht/irrlicht-1.8.1-sysctl.patch
new file mode 100644
index 0000000000..35f8aa5c86
--- /dev/null
+++ b/testing/irrlicht/irrlicht-1.8.1-sysctl.patch
@@ -0,0 +1,11 @@
+--- a/source/Irrlicht/COSOperator.cpp.orig
++++ b/source/Irrlicht/COSOperator.cpp
+@@ -13,7 +13,7 @@
+ #include <unistd.h>
+ #ifndef _IRR_SOLARIS_PLATFORM_
+ #include <sys/types.h>
+-#include <sys/sysctl.h>
++//#include <sys/sysctl.h>
+ #endif
+ #endif
+