aboutsummaryrefslogtreecommitdiffstats
path: root/testing/iscsi-scst-svn
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2010-05-27 09:26:53 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2010-05-27 09:26:53 +0000
commit21405ea6a5c33114bb6ec07185e56d4c2704b989 (patch)
tree9d599a374b6e7953e50d9731c684b81bdd688295 /testing/iscsi-scst-svn
parente14dd28447d272027ebd9bf045eb0a6bd428f0c2 (diff)
downloadaports-21405ea6a5c33114bb6ec07185e56d4c2704b989.tar.bz2
aports-21405ea6a5c33114bb6ec07185e56d4c2704b989.tar.xz
testing/[scst]: merge scst from experimental to master
Diffstat (limited to 'testing/iscsi-scst-svn')
-rw-r--r--testing/iscsi-scst-svn/APKBUILD40
-rw-r--r--testing/iscsi-scst-svn/iscsi-scst.initd23
2 files changed, 63 insertions, 0 deletions
diff --git a/testing/iscsi-scst-svn/APKBUILD b/testing/iscsi-scst-svn/APKBUILD
new file mode 100644
index 0000000000..9b3ec42008
--- /dev/null
+++ b/testing/iscsi-scst-svn/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+pkgname=iscsi-scst-svn
+pkgver=1713
+pkgrel=0
+pkgdesc="ISCSI target for SCST - userspace tools"
+url="http://iscsi-scst.sourceforge.net/"
+license="GPL-2"
+depends=
+install=
+makedepends="openssl-dev scst-svn-scst-dev"
+subpackages=
+source="http://alpine.nethq.org/clandmeter/src/$pkgname-$pkgver.tar.gz
+ iscsi-scst.initd
+ "
+
+_builddir="$srcdir"/iscsi-scst
+prepare() {
+ cd "$_builddir"
+ # we need the headre file. fix dependency in makefile
+ sed -i -e 's/^\(progs:.*\)/\1 include\/iscsi_scst_itf_ver.h/' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make progs \
+ SCST_INC_DIR=/usr/include/scst
+}
+
+package() {
+ cd "$_builddir"
+ # make install is broken
+ install -D usr/iscsi-scstd "$pkgdir"/usr/sbin/iscsi-scstd
+ install -D usr/iscsi-scst-adm "$pkgdir"/usr/sbin/iscsi-scst-adm
+ install -D -m 755 "$srcdir"/iscsi-scst.initd "$pkgdir"/etc/init.d/iscsi-scst
+}
+
+md5sums="cf046db4f7cd9cf969b054dc055922d6 iscsi-scst-svn-1713.tar.gz
+3132fae1ec2f9bcc72476d9e9f36d326 iscsi-scst.initd"
diff --git a/testing/iscsi-scst-svn/iscsi-scst.initd b/testing/iscsi-scst-svn/iscsi-scst.initd
new file mode 100644
index 0000000000..4d4cd76b59
--- /dev/null
+++ b/testing/iscsi-scst-svn/iscsi-scst.initd
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+#
+# Start the iSCSI-SCST Target.
+#
+
+depend() {
+ need net
+ afer firewall
+}
+
+start() {
+ modprobe -q crc32c
+ modprobe -q iscsi-scst
+ ebegin "Starting iscsi-scstd"
+ start-stop-daemon --start --exec /usr/sbin/iscsi-scstd
+ eend 0
+}
+
+stop() {
+ ebegin "Stopping iscsi-scstd"
+ start-stop-daemon --stop --exec /usr/sbin/iscsi-scstd
+ eend 0
+}