aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jhead/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-12-11 04:46:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 13:52:01 +0000
commit1e5183ee6e07480e59d1863094d74795a8a8662f (patch)
tree363b82c15a04fad4c0ab1260232513634ff56ab5 /testing/jhead/APKBUILD
parent42d8f3ac74f86c7d696928aae3ea8ca69c581c09 (diff)
downloadaports-1e5183ee6e07480e59d1863094d74795a8a8662f.tar.bz2
aports-1e5183ee6e07480e59d1863094d74795a8a8662f.tar.xz
Initial APKBUILD for jhead
Package description: This package provides a tool for displaying and manipulating non-image portions of EXIF format JPEG image files, as produced by most digital cameras. Website: http://www.sentex.net/~mwandel/jhead/
Diffstat (limited to 'testing/jhead/APKBUILD')
-rw-r--r--testing/jhead/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/jhead/APKBUILD b/testing/jhead/APKBUILD
new file mode 100644
index 0000000000..961b59d6c2
--- /dev/null
+++ b/testing/jhead/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=jhead
+pkgver=2.93
+pkgrel=0
+pkgdesc="An Exif jpeg header manipulation tool"
+url="http://www.sentex.net/~mwandel/jhead/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.sentex.net/~mwandel/$pkgname/$pkgname-$pkgver.tar.gz
+ makefile-destdir.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="23ac51b4aea2df663d684744e282eb7d jhead-2.93.tar.gz
+c0daea2a99f121ea84adb2fce47e0a4e makefile-destdir.patch"