aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jhead
diff options
context:
space:
mode:
authorRichard Mortier <mort@cantab.net>2019-01-01 23:58:44 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 10:35:41 +0000
commit304e0ee9859b7fdc51c95f2feb97a2340397b1e8 (patch)
tree6e73ce9461a07510e4a2e179ee4948fa8d106b25 /testing/jhead
parent0ffbcc6e5d2c475218afcdb0e94e9424d298bf16 (diff)
downloadaports-304e0ee9859b7fdc51c95f2feb97a2340397b1e8.tar.bz2
aports-304e0ee9859b7fdc51c95f2feb97a2340397b1e8.tar.xz
testing/jhead: new aport
http://www.sentex.net/~mwandel/jhead/ Exif Jpeg header manipulation tool Signed-off-by: Richard Mortier <mort@cantab.net>
Diffstat (limited to 'testing/jhead')
-rw-r--r--testing/jhead/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/jhead/APKBUILD b/testing/jhead/APKBUILD
new file mode 100644
index 0000000000..fe396442d7
--- /dev/null
+++ b/testing/jhead/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Richard Mortier <mort@cantab.net>
+# Maintainer: Richard Mortier <mort@cantab.net>
+pkgname=jhead
+pkgver=3.03
+pkgrel=0
+pkgdesc="Exif Jpeg header manipulation tool"
+url="http://www.sentex.net/~mwandel/jhead/"
+arch="all"
+license="custom"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.sentex.net/~mwandel/jhead/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # no test suite
+
+build() {
+ cd "$builddir"
+ make all
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 jhead "$pkgdir"/usr/bin/jhead
+}
+
+doc() {
+ cd "$builddir"
+ gzip -v9 jhead.1
+ install -Dm644 jhead.1.gz "$subpkgdir"/usr/share/man/man1/jhead.1.gz
+ install -Dm644 readme.txt \
+ "$subpkgdir"/usr/share/licenses/$pkgname/readme.txt
+}
+
+sha512sums="3e1e5277ae3d22ed04a35cece42690e76f9f6196ab396cc7917ae27a1ebabae79ae359454d5a0597597b278c7e2e5e5766f5a5f6b57dc72a2aaf429e809dbb29 jhead-3.03.tar.gz"