aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jitterentropy-rngd
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-04-23 14:42:55 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-23 20:46:06 +0000
commit7bef0f89635ff57d38bd7ef7fc686236b3695926 (patch)
treeac9c5358b4e7a22681feca5db122bd789d13bf2e /testing/jitterentropy-rngd
parentfd86def43690bcff83185945c6ee22179c6126b6 (diff)
downloadaports-7bef0f89635ff57d38bd7ef7fc686236b3695926.tar.bz2
aports-7bef0f89635ff57d38bd7ef7fc686236b3695926.tar.xz
testing/jitterentropy-rngd: new aport
Diffstat (limited to 'testing/jitterentropy-rngd')
-rw-r--r--testing/jitterentropy-rngd/APKBUILD30
-rw-r--r--testing/jitterentropy-rngd/jitterentropy-rngd.initd13
2 files changed, 43 insertions, 0 deletions
diff --git a/testing/jitterentropy-rngd/APKBUILD b/testing/jitterentropy-rngd/APKBUILD
new file mode 100644
index 0000000000..857f6f1bba
--- /dev/null
+++ b/testing/jitterentropy-rngd/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer:
+pkgname=jitterentropy-rngd
+pkgver=1.0.8
+pkgrel=0
+pkgdesc="CPU Jitter RNG Daemon"
+url="http://www.chronox.de/jent.html"
+arch="all"
+license="GPL-2.0 BSD-3-Clause"
+makedepends="linux-headers"
+options="!check" # no test suite
+subpackages="$pkgname-doc $pkgname-openrc"
+source="jitterentropy-rngd-$pkgver.tar.gz::https://github.com/smuellerDD/jitterentropy-rngd/archive/v$pkgver.tar.gz
+ $pkgname.initd
+ "
+builddir="$srcdir/jitterentropy-rngd-$pkgver"
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+}
+
+sha512sums="57b9e59f2aa7c440b5e250e01c3a9dc1943407fffaf99b2cc7ca1bf6229d1f403c2a856105ebb4ea6af21a0db436141dbfb0754af4bdcebc01a41b9c8c888d08 jitterentropy-rngd-1.0.8.tar.gz
+5903286b2bec9aedd7f05c7e95ac464709479f802467ac749a51794074ee15b819582c6b6993520ee3a9acb505994683edb739b45932b55d16e53bb42df8cc39 jitterentropy-rngd.initd"
diff --git a/testing/jitterentropy-rngd/jitterentropy-rngd.initd b/testing/jitterentropy-rngd/jitterentropy-rngd.initd
new file mode 100644
index 0000000000..ebd8b92358
--- /dev/null
+++ b/testing/jitterentropy-rngd/jitterentropy-rngd.initd
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+
+description="CPU Jitter Random number generator daemon"
+
+pidfile=/run/$RC_SVCNAME.pid
+command=/usr/sbin/jitterentropy-rngd
+command_args="--pid $pidfile"
+
+depend() {
+ need localmount
+ after urandom
+ provide entropy
+}