aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jo
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-07 07:42:52 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-07 07:51:19 +0100
commit5f234449f135f59eee320ec876d77a538ac5a34d (patch)
tree6281dcf0d1440573930f327062b426dfa9379cef /testing/jo
parent804de5bb63cd88fbb4d5d692283dd09b3897672c (diff)
downloadaports-5f234449f135f59eee320ec876d77a538ac5a34d.tar.bz2
aports-5f234449f135f59eee320ec876d77a538ac5a34d.tar.xz
testing/jo: upgrade to 1.3
Diffstat (limited to 'testing/jo')
-rw-r--r--testing/jo/APKBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/testing/jo/APKBUILD b/testing/jo/APKBUILD
index a14af584bb..97328255b7 100644
--- a/testing/jo/APKBUILD
+++ b/testing/jo/APKBUILD
@@ -1,19 +1,18 @@
# Contributor: Orion <systmkor@gmail.com>
# Maintainer: Orion <systmkor@gmail.com>
pkgname=jo
-pkgver=1.2
+pkgver=1.3
pkgrel=0
pkgdesc="JSON output from a shell"
url="https://github.com/jpmens/jo/"
arch="all"
-license="GPL-2.0"
-subpackages="$pkgname-doc"
-source="https://github.com/jpmens/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-
-builddir=${srcdir}/${pkgname}-${pkgver}
+license="GPL-2.0-or-later"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch"
+source="https://github.com/jpmens/jo/releases/download/$pkgver/jo-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,13 +24,21 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="72dd61bf5b9882c1cd5f6b62b2c9f6b0141546168915a389876712c82388f3105a5b91ffd3775b15c3a8bfb0d7f577ccb29a2fb4d3d7b85416d87d07047312c3 jo-1.2.tar.gz"
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
+ mv "$pkgdir"/etc/bash_completion.d \
+ "$subpkgdir"/usr/share/bash-completion/completions
+}
+
+sha512sums="3c9480257d0ab9d9f19f1aaeb3a5b72e69caff6dcf87118bea8aca74a3b0864c0d17ed52bfc5550783c4636ee3a6acb8578f08316d976cea4f06af7096c12f02 jo-1.3.tar.gz"