aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jsonnet/use-real-sys-gtest.patch
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-06-19 22:17:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-20 10:13:09 -0300
commit15aa878b0dd21efa1aef2518baaf60ba57571daf (patch)
tree55a5f935cd86eb1439da50452ed9838ea1775e8c /testing/jsonnet/use-real-sys-gtest.patch
parent19b9749b21c861c7f19505796b8f5df2ff191793 (diff)
downloadaports-15aa878b0dd21efa1aef2518baaf60ba57571daf.tar.bz2
aports-15aa878b0dd21efa1aef2518baaf60ba57571daf.tar.xz
testing/jsonnet: new aport
Diffstat (limited to 'testing/jsonnet/use-real-sys-gtest.patch')
-rw-r--r--testing/jsonnet/use-real-sys-gtest.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/testing/jsonnet/use-real-sys-gtest.patch b/testing/jsonnet/use-real-sys-gtest.patch
new file mode 100644
index 0000000000..d4c00573e0
--- /dev/null
+++ b/testing/jsonnet/use-real-sys-gtest.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -72,8 +72,9 @@
+ include_directories("${gtest_SOURCE_DIR}/include")
+
+ elseif (BUILD_TESTS AND USE_SYSTEM_GTEST)
+- enable_testing()
+- add_subdirectory(/usr/src/googletest ${GLOBAL_OUTPUT_PATH}/googletest-build)
++ enable_testing()
++ find_package(GTest REQUIRED)
++ include_directories(${GTEST_INCLUDE_DIR})
+ endif()
+
+ # Compiler flags.