aboutsummaryrefslogtreecommitdiffstats
path: root/testing/julia/0001-hardened.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-06 15:27:58 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-06-09 19:26:06 +0200
commit306b71cdc16ae6765d310b354deb6c716728c815 (patch)
treec9c724b5a55abba0ff059eeb66e91df97a00f757 /testing/julia/0001-hardened.patch
parentba48a053791c950c7d8aedc52bd8da4269073c6f (diff)
downloadaports-306b71cdc16ae6765d310b354deb6c716728c815.tar.bz2
aports-306b71cdc16ae6765d310b354deb6c716728c815.tar.xz
testing/julia: new abuild
http://julialang.org/ A high-level, high-performance dynamic language for technical computing.
Diffstat (limited to 'testing/julia/0001-hardened.patch')
-rw-r--r--testing/julia/0001-hardened.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/julia/0001-hardened.patch b/testing/julia/0001-hardened.patch
new file mode 100644
index 0000000000..2984356c7b
--- /dev/null
+++ b/testing/julia/0001-hardened.patch
@@ -0,0 +1,29 @@
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sun, 05 Jun 2016 14:11:00 +0200
+Subject: [PATCH] Disable PaX memory protection for julia binary
+--- a/Makefile
++++ b/Makefile
+@@ -71,7 +71,13 @@
+ julia-sysimg-debug : julia-inference julia-ui-debug
+ @$(MAKE) $(QUIET_MAKE) $(build_private_libdir)/sys-debug.$(SHLIB_EXT) JULIA_BUILD_MODE=debug
+
+-julia-debug julia-release : julia-% : julia-ui-% julia-sysimg-% julia-symlink julia-libccalltest
++julia-pax-release : julia-ui-release
++ paxmark m $(JULIA_EXECUTABLE_release)
++
++julia-pax-debug : julia-ui-debug
++ paxmark m $(JULIA_EXECUTABLE_debug)
++
++julia-debug julia-release : julia-% : julia-ui-% julia-pax-% julia-sysimg-% julia-symlink julia-libccalltest
+
+ debug release : % : julia-%
+
+@@ -527,7 +533,7 @@
+ test testall testall1 test clean distcleanall cleanall clean-* \
+ run-julia run-julia-debug run-julia-release run \
+ install binary-dist light-source-dist.tmp light-source-dist \
+- dist full-source-dist source-dist
++ dist full-source-dist source-dist julia-pax-release julia-pax-debug
+
+ test: check-whitespace $(JULIA_BUILD_MODE)
+ @$(MAKE) $(QUIET_MAKE) -C test default JULIA_BUILD_MODE=$(JULIA_BUILD_MODE)