aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kaccounts-integration/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-22 18:28:47 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-22 16:08:11 -0300
commit9ca507cf86071d32fc648101fd810b772102de71 (patch)
tree3454823b85112f1ec580b32f375987578b71d9be /testing/kaccounts-integration/APKBUILD
parentecf417fffb4856f05fddce777f0181946f2091cb (diff)
downloadaports-9ca507cf86071d32fc648101fd810b772102de71.tar.bz2
aports-9ca507cf86071d32fc648101fd810b772102de71.tar.xz
testing/kaccounts-integration: new aport
Diffstat (limited to 'testing/kaccounts-integration/APKBUILD')
-rw-r--r--testing/kaccounts-integration/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/kaccounts-integration/APKBUILD b/testing/kaccounts-integration/APKBUILD
new file mode 100644
index 0000000000..81343444c1
--- /dev/null
+++ b/testing/kaccounts-integration/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kaccounts-integration
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/internet/"
+pkgdesc="Small system to administer web accounts for the sites and services across the KDE desktop"
+license="GPL-2.0-or-later AND LGPL-2.1-or-later"
+depends_dev="qt5-qtbase-dev kcmutils-dev ki18n-dev kcoreaddons-dev kdbusaddons-dev kdeclarative-dev libaccounts-qt-dev signond-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+options="!check" # No tests available
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="77335fd257dab8ef5e1d41eba34effb1bdbc3b7b177e37af0b203be42650f16be30a1786f23c6ecde9121d19ab6f381922aca1773a780f3cad15f5aea2d62aa5 kaccounts-integration-19.04.2.tar.xz"