aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kapptemplate
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-16 22:45:10 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-16 17:46:44 -0300
commitefd78c8161460911e14880d8fcfb4b4cae3c8667 (patch)
treede57d39aa9eea24f77e1912933f5b10f3bd05af5 /testing/kapptemplate
parent2868da4f6f18fcf448c762547b385886e06aca64 (diff)
downloadaports-efd78c8161460911e14880d8fcfb4b4cae3c8667.tar.bz2
aports-efd78c8161460911e14880d8fcfb4b4cae3c8667.tar.xz
testing/kapptemplate: new aport
Diffstat (limited to 'testing/kapptemplate')
-rw-r--r--testing/kapptemplate/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/kapptemplate/APKBUILD b/testing/kapptemplate/APKBUILD
new file mode 100644
index 0000000000..1e113f00f4
--- /dev/null
+++ b/testing/kapptemplate/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kapptemplate
+pkgver=19.04.3
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/development/org.kde.kapptemplate"
+pkgdesc="Factory for the easy creation of KDE/Qt components and programs"
+license="GPL-2.0-or-lateri AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcoreaddons-dev kconfigwidgets-dev kcompletion-dev karchive-dev kio-dev ki18n-dev kdoctools-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="d19f6c406ab68cbf1c98dd451e96f21b5d5167908c06613b8adea977127d916fc00da0de5644f0f5342f589d9caf847ee00d7c13d3865c3a4f1b516adf87aac2 kapptemplate-19.04.3.tar.xz"