aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kbackup
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-16 00:52:43 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-15 22:07:20 -0300
commit5c87fab1ba54d667299b0e538c87228998dfd97a (patch)
tree2f2dcfd5cbd317078b36d9b6e809452da682d6ba /testing/kbackup
parent4a7bb00e574270e6fcc6ce1ed598188af74237ab (diff)
downloadaports-5c87fab1ba54d667299b0e538c87228998dfd97a.tar.bz2
aports-5c87fab1ba54d667299b0e538c87228998dfd97a.tar.xz
testing/kbackup: new aport
Diffstat (limited to 'testing/kbackup')
-rw-r--r--testing/kbackup/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/kbackup/APKBUILD b/testing/kbackup/APKBUILD
new file mode 100644
index 0000000000..e7ae4bb233
--- /dev/null
+++ b/testing/kbackup/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kbackup
+pkgver=19.04.3
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/utilities/org.kde.kbackup"
+pkgdesc="An application which lets you back up your data in a simple, user friendly way"
+license="GPL-2.0-or-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev knotifications-dev ki18n-dev kio-dev kdoctools-dev kxmlgui-dev kiconthemes-dev karchive-dev kwidgetsaddons-dev shared-mime-info"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="46134dc3028fb0c81f906ed111155e2e141793c63fe4215cca9f04dc0edc740d4a05ed28d99f26c973ca9a2caf8cae19b99244368f8728416a9eb65240c607d4 kbackup-19.04.3.tar.xz"