aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kbuild/strlcpy.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-01-02 10:40:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-01-02 10:52:48 +0000
commitfd024b04f62ceb810b5ce5c0eb740277cb7651ac (patch)
tree5d9b9290738e7902d9f3c50101713141ecdaa991 /testing/kbuild/strlcpy.patch
parentb705597922992e151deeda07f70804f6733af810 (diff)
downloadaports-fd024b04f62ceb810b5ce5c0eb740277cb7651ac.tar.bz2
aports-fd024b04f62ceb810b5ce5c0eb740277cb7651ac.tar.xz
testing/kbuild: upgrade to 0.1.9998_pre20131130 and fix build on musl
Diffstat (limited to 'testing/kbuild/strlcpy.patch')
-rw-r--r--testing/kbuild/strlcpy.patch15
1 files changed, 1 insertions, 14 deletions
diff --git a/testing/kbuild/strlcpy.patch b/testing/kbuild/strlcpy.patch
index 42b25bdadf..d0b3a0471d 100644
--- a/testing/kbuild/strlcpy.patch
+++ b/testing/kbuild/strlcpy.patch
@@ -7,20 +7,7 @@ index 44b76ab..85fec01 100644
#include "kbuild_protection.h"
-#if defined(_MSC_VER) || defined(__gnu_linux__) || defined(__linux__)
-+#if defined(_MSC_VER) || defined(__gnu_linux__) || defined(__linux__) && !defined(__UCLIBC__)
++#if defined(_MSC_VER) || defined(__gnu_linux__) && !defined(__UCLIBC__)
extern char *strlcpy(char *, const char *, size_t);
#endif
-diff --git a/src/kmk/Makefile.kmk b/src/kmk/Makefile.kmk
-index 12b9697..db1deb2 100644
---- a/src/kmk/Makefile.kmk
-+++ b/src/kmk/Makefile.kmk
-@@ -101,7 +101,7 @@ kmkmissing_SOURCES.freebsd = \
- glob/fnmatch.c
-
- kmkmissing_SOURCES.linux += \
-- kmkbuiltin/strlcpy.c
-+ getloadavg.c
-
- kmkmissing_SOURCES.solaris = \
- kmkbuiltin/strlcpy.c \