aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kbuild/strlcpy.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-23 19:58:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-23 19:58:16 +0000
commit3a044aaeb7856d4c0f4cf1be8da64027b686d452 (patch)
tree168a0a0e8feb1daa86e860a0f6817d6ff4d0a972 /testing/kbuild/strlcpy.patch
parentcd89b051ddac83b13379b776dcbf0c591e878667 (diff)
downloadaports-3a044aaeb7856d4c0f4cf1be8da64027b686d452.tar.bz2
aports-3a044aaeb7856d4c0f4cf1be8da64027b686d452.tar.xz
testing/kbuild: new aport
A makefile framework for writing simple makefiles for complex tasks http://svn.netlabs.org/kbuild/wiki needed for virtualbox
Diffstat (limited to 'testing/kbuild/strlcpy.patch')
-rw-r--r--testing/kbuild/strlcpy.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/kbuild/strlcpy.patch b/testing/kbuild/strlcpy.patch
new file mode 100644
index 0000000000..42b25bdadf
--- /dev/null
+++ b/testing/kbuild/strlcpy.patch
@@ -0,0 +1,26 @@
+diff --git a/src/kmk/kmkbuiltin/cp.c b/src/kmk/kmkbuiltin/cp.c
+index 44b76ab..85fec01 100644
+--- a/src/kmk/kmkbuiltin/cp.c
++++ b/src/kmk/kmkbuiltin/cp.c
+@@ -81,7 +81,7 @@ __FBSDID("$FreeBSD: src/bin/cp/cp.c,v 1.50 2004/04/06 20:06:44 markm Exp $");
+ #include "kmkbuiltin.h"
+ #include "kbuild_protection.h"
+
+-#if defined(_MSC_VER) || defined(__gnu_linux__) || defined(__linux__)
++#if defined(_MSC_VER) || defined(__gnu_linux__) || defined(__linux__) && !defined(__UCLIBC__)
+ extern char *strlcpy(char *, const char *, size_t);
+ #endif
+
+diff --git a/src/kmk/Makefile.kmk b/src/kmk/Makefile.kmk
+index 12b9697..db1deb2 100644
+--- a/src/kmk/Makefile.kmk
++++ b/src/kmk/Makefile.kmk
+@@ -101,7 +101,7 @@ kmkmissing_SOURCES.freebsd = \
+ glob/fnmatch.c
+
+ kmkmissing_SOURCES.linux += \
+- kmkbuiltin/strlcpy.c
++ getloadavg.c
+
+ kmkmissing_SOURCES.solaris = \
+ kmkbuiltin/strlcpy.c \