aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kcontacts
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-08-23 16:44:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-23 16:46:32 -0300
commit7f3b48cb4d4b49eb87f2ee5b17ec144536530d45 (patch)
treed66713f186e52bf88cc25e89894b7d950cbf1897 /testing/kcontacts
parent62c3585336bfda3851eb1eb254fb48618661fd27 (diff)
downloadaports-7f3b48cb4d4b49eb87f2ee5b17ec144536530d45.tar.bz2
aports-7f3b48cb4d4b49eb87f2ee5b17ec144536530d45.tar.xz
teting/kde-applications: upgrade to 19.08.0
Diffstat (limited to 'testing/kcontacts')
-rw-r--r--testing/kcontacts/APKBUILD13
-rw-r--r--testing/kcontacts/D20268.patch126
-rw-r--r--testing/kcontacts/D20866.patch71
-rw-r--r--testing/kcontacts/help-doxygen-to-see-section-title-on-addressformat.patch22
4 files changed, 3 insertions, 229 deletions
diff --git a/testing/kcontacts/APKBUILD b/testing/kcontacts/APKBUILD
index ea7116e9eb..a5d8b58cd2 100644
--- a/testing/kcontacts/APKBUILD
+++ b/testing/kcontacts/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcontacts
-pkgver=19.04.3
+pkgver=19.08.0
pkgrel=0
pkgdesc="Address book API for KDE"
arch="all"
@@ -11,11 +11,7 @@ depends="iso-codes"
depends_dev="qt5-qtbase-dev kcoreaddons-dev ki18n-dev kconfig-dev kcodecs-dev"
makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz
- D20268.patch
- D20866.patch
- help-doxygen-to-see-section-title-on-addressformat.patch
-"
+source="https://download.kde.org/stable/applications/$pkgver/src/kcontacts-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
build() {
@@ -34,7 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" make install
}
-sha512sums="1b2fb2a2e13e9e5b25845c92fbf1ff27bd5a8ec3f2e72447a7969782c2e0fdadf91d95a5c4f14296247415420bcfcb5097d3b69017ab243587a02f2c820666b8 kcontacts-19.04.3.tar.xz
-d9517807a3958b1db90e187be1129dc211014224edb60bf47dc96dd7f27998079afacd5c18fa2e2af7942d99f1a7da75cae1cb7cbfb119f46f5a1d3bd5be6b7b D20268.patch
-d0d403e1d26951f112852eabb3a1d1aea4c3cf69115fb9fb1f26abdf6ce5a2e4a98fa901be8c73552f4032b9ed743cac5319913afa132ac056ca192ffdd67624 D20866.patch
-ff9ec5fc23ac6efbe5c9abdb554e162cba684fec7afa29e5608618debc3c53331ed4a8bec861557fffb168ca9863f4de4cac09f9570df9e00b9a54dd668ab702 help-doxygen-to-see-section-title-on-addressformat.patch"
+sha512sums="c1bf8734531e95fe9555144d978ca8c90073c0fa95cde78986e14a312fee54c45736c5b1990eaa0ff29936426a1be551313b81604b0f5cddc27a6ed17e9bc124 kcontacts-19.08.0.tar.xz"
diff --git a/testing/kcontacts/D20268.patch b/testing/kcontacts/D20268.patch
deleted file mode 100644
index 54e211e5c2..0000000000
--- a/testing/kcontacts/D20268.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-diff --git a/README b/README
-deleted file mode 100644
---- a/README
-+++ /dev/null
-@@ -1,28 +0,0 @@
--KContacts - new address book API for KDE
--
--PURPOSE:
--
--KCcontacts provides an API for address book data. This can be used by all
--application using data of this type, e.g. KAddressBook, KMail, KOrganizer,
--etc.
--
--FEATURES:
--
--- Value based interface, addressbook entry data is implicitly shared.
--- Address book entries are identified by a unique id.
--- vCard backend (RFC 2425 / RFC 2426).
--- Locking mechanism to support concurrent access to the address book by
-- multiple processes.
--- Notification on change of addressbook by other process.
--- Dialog for selecting address book entries, supports mouse and keyboard
-- selection, supports automatic name completion.
--- GUI client for viewing, modifying address book data. This is aimed at
-- developers not end users.
--- Tool for converting data, written with libkab, to libkabc format.
--- Multiple backends (resources) for storing entries e.g. LDAP
--
--AUTHOR: Cornelius Schumacher <schumacher@kde.org>
--
--LICENCE: LGPL
--
--DATE: 13 Oct 2001
-diff --git a/README.md b/README.md
---- a/README.md
-+++ b/README.md
-@@ -1,3 +1,11 @@
--# KContact
-+# KContacts
-
--KContact library provides vcard support
-+KContact provides an API for contacts/address book data following the
-+vCard standard (RFC 2425 / RFC 2426).
-+
-+## Features
-+- vCard data model (see KContacts::Addressee).
-+- vCard input/output (see KContacts::VCardConverter).
-+- Contact group management (see KContacts::ContactGroup).
-+- Locale-aware address formatting (see KContacts::Address).
-+- Localized country name to ISO 3166-1 alpha 2 code mapping and vice verca (see KContacts::Address).
-diff --git a/README.AddressFormat b/docs/AddressFormat.md
-rename from README.AddressFormat
-rename to docs/AddressFormat.md
---- a/README.AddressFormat
-+++ b/docs/AddressFormat.md
-@@ -1,3 +1,5 @@
-+# Localized Address Formats
-+
- Address formats can be a tricky thing. KContacts tries very hard to perfectly fit
- the needs of ~95% of users and to be at least sufficient for the other 5%.
-
-@@ -26,8 +28,9 @@
-
- -Jost.
-
--Fields AddressFormat and BusinessAddressFormat
--------------------------------------------------
-+## Fields AddressFormat and BusinessAddressFormat
-+
-+```
- %n = real name
- %N = REAL NAME
- %cm = company
-@@ -49,16 +52,18 @@
- address doesn't have a postbox, the string %0(PO Box %p) will not
- evaluate to "PO Box " but to an empty string.
- \n = newline
-+```
-
--Field AddressCountryPosition
--------------------------------------------------
-+## Field AddressCountryPosition
-+```
- below = country name below rest of address
- BELOW = country name below in capital letters
- above = country name above rest of address
- ABOVE = country name above in capital letters
-+```
-+
-+## Some Tips
-
--Some Tips
--------------------------------------------------
- - You sometimes have three fields in a line which can all be empty. If you eg.
- separate them all with conditional whitespace (same goes for cond. comma) like
- in "%z%w%r%w%l" and only the middle value (here: region) is empty, there will
-diff --git a/metainfo.yaml b/metainfo.yaml
---- a/metainfo.yaml
-+++ b/metainfo.yaml
-@@ -1,6 +1,6 @@
- maintainer: mlaurent
- description: Address book API for KDE
--tier: 3
-+tier: 2
- type: functional
- public_lib: true
- group: kdepim
-diff --git a/src/addresseelist.h b/src/addresseelist.h
---- a/src/addresseelist.h
-+++ b/src/addresseelist.h
-@@ -265,11 +265,11 @@
- } SortingCriterion;
-
- /**
-- * @short a QValueList of Addressee, with sorting functionality
-+ * @short a QVector of Addressee, with sorting functionality
- *
-- * This class extends the functionality of QValueList with
-+ * This class extends the functionality of QVector with
- * sorting methods specific to the Addressee class. It can be used
-- * just like any other QValueList but is no template class.
-+ * just like any other QVector but is no template class.
- *
- * An AddresseeList does not automatically keep sorted when addressees
- * are added or removed or the sorting order is changed, as this would
-
diff --git a/testing/kcontacts/D20866.patch b/testing/kcontacts/D20866.patch
deleted file mode 100644
index d8b0536729..0000000000
--- a/testing/kcontacts/D20866.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -21,9 +21,10 @@
- include(KDECMakeSettings)
- include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
- include(ECMQtDeclareLoggingCategory)
-+include(ECMAddQch)
-
--
--
-+option(BUILD_QCH "Build API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)" OFF)
-+add_feature_info(QCH ${BUILD_QCH} "API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)")
-
- set(KCONTACTS_LIB_VERSION ${PIM_VERSION})
-
-@@ -60,6 +61,16 @@
- ########### CMake Config Files ###########
- set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_CMAKEPACKAGEDIR}/KF5Contacts")
-
-+if (BUILD_QCH)
-+ ecm_install_qch_export(
-+ TARGETS KF5Contacts_QCH
-+ FILE KF5ContactsQchTargets.cmake
-+ DESTINATION "${CMAKECONFIG_INSTALL_DIR}"
-+ COMPONENT Devel
-+ )
-+ set(PACKAGE_INCLUDE_QCHTARGETS "include(\"\${CMAKE_CURRENT_LIST_DIR}/KF5ContactsQchTargets.cmake\")")
-+endif()
-+
- configure_package_config_file(
- "${CMAKE_CURRENT_SOURCE_DIR}/KF5ContactsConfig.cmake.in"
- "${CMAKE_CURRENT_BINARY_DIR}/KF5ContactsConfig.cmake"
-diff --git a/KF5ContactsConfig.cmake.in b/KF5ContactsConfig.cmake.in
---- a/KF5ContactsConfig.cmake.in
-+++ b/KF5ContactsConfig.cmake.in
-@@ -6,3 +6,5 @@
- find_dependency(KF5Codecs "@KF5_MIN_VERSION@")
-
- include("${CMAKE_CURRENT_LIST_DIR}/KF5ContactsTargets.cmake")
-+
-+@PACKAGE_INCLUDE_QCHTARGETS@
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -129,3 +129,24 @@
-
- ecm_generate_pri_file(BASE_NAME KContacts LIB_NAME KF5Contacts DEPS "CoreAddons" FILENAME_VAR PRI_FILENAME INCLUDE_INSTALL_DIR ${KDE_INSTALL_INCLUDEDIR_KF5}/KContacts)
- install(FILES ${PRI_FILENAME} DESTINATION ${ECM_MKSPECS_INSTALL_DIR})
-+
-+if(BUILD_QCH)
-+ ecm_add_qch(
-+ KF5Contacts_QCH
-+ NAME KContacts
-+ BASE_NAME KF5Contacts
-+ VERSION ${KContacts_VERSION_STRING}
-+ ORG_DOMAIN org.kde
-+ SOURCES # using only public headers, to cover only public API
-+ ${KContacts_HEADERS}
-+ "${CMAKE_SOURCE_DIR}/docs/AddressFormat.md"
-+ MD_MAINPAGE "${CMAKE_SOURCE_DIR}/README.md"
-+ LINK_QCHS
-+ Qt5Core_QCH
-+ BLANK_MACROS
-+ KCONTACTS_EXPORT
-+ TAGFILE_INSTALL_DESTINATION ${KDE_INSTALL_QTQCHDIR}
-+ QCH_INSTALL_DESTINATION ${KDE_INSTALL_QTQCHDIR}
-+ COMPONENT Devel
-+ )
-+endif()
-
diff --git a/testing/kcontacts/help-doxygen-to-see-section-title-on-addressformat.patch b/testing/kcontacts/help-doxygen-to-see-section-title-on-addressformat.patch
deleted file mode 100644
index 6109f81bfe..0000000000
--- a/testing/kcontacts/help-doxygen-to-see-section-title-on-addressformat.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From cbb660e18d755cf236ff4efcef371a5a4beb2c69 Mon Sep 17 00:00:00 2001
-From: "Friedrich W. H. Kossebau" <kossebau@kde.org>
-Date: Mon, 29 Apr 2019 14:32:10 +0200
-Subject: [PATCH] API dox: help doxygen to see section title on
- AddressFormat.md
-
----
- docs/AddressFormat.md | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/docs/AddressFormat.md b/docs/AddressFormat.md
-index 9abf3d13..a313f473 100644
---- a/docs/AddressFormat.md
-+++ b/docs/AddressFormat.md
-@@ -55,6 +55,7 @@ Any comments very very welcome to kde-pim@kde.org or to jost@schenck.de.
- ```
-
- ## Field AddressCountryPosition
-+
- ```
- below = country name below rest of address
- BELOW = country name below in capital letters