aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kdbusaddons
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-22 00:42:09 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-28 17:14:48 +0000
commitfeaa3b5b8563336996ba368d853ea7de91f9ac42 (patch)
tree44136ee58286f5b41f5a3ac5900f1d6b2d789b72 /testing/kdbusaddons
parentfacd5f1b05cbe462f21860ce84c7e8fcc351466e (diff)
downloadaports-feaa3b5b8563336996ba368d853ea7de91f9ac42.tar.bz2
aports-feaa3b5b8563336996ba368d853ea7de91f9ac42.tar.xz
testing/kdbusaddons: new aport
Closes GH-7992
Diffstat (limited to 'testing/kdbusaddons')
-rw-r--r--testing/kdbusaddons/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/kdbusaddons/APKBUILD b/testing/kdbusaddons/APKBUILD
new file mode 100644
index 0000000000..13cd622372
--- /dev/null
+++ b/testing/kdbusaddons/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdbusaddons
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Addons to QtDBus"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+makedepends="extra-cmake-modules qt5-qttools-dev doxygen shared-mime-info"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+options="!check" # Requires running dbus-daemon
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="ddba1e9d535be578f68deea2e38919db691cdb25719b18197d13fd98a0d81ad537550b4b0f0243971741c30dc0fb1b9a242b56310fa52c756c1911b76b880002 kdbusaddons-5.58.0.tar.xz"