aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kdenetwork-filesharing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-25 14:42:07 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-25 10:53:26 -0300
commit1bc2a8f92d57b6bf06addd282f7bfc95c02515bc (patch)
tree30f192c37e0410fa505aa6a548ee8eaf827f8af9 /testing/kdenetwork-filesharing
parent1eee09a8ec819b7a1b4f322a1fef7e207c99364e (diff)
downloadaports-1bc2a8f92d57b6bf06addd282f7bfc95c02515bc.tar.bz2
aports-1bc2a8f92d57b6bf06addd282f7bfc95c02515bc.tar.xz
testing/kdenetwork-filesharing: new aport
Diffstat (limited to 'testing/kdenetwork-filesharing')
-rw-r--r--testing/kdenetwork-filesharing/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/kdenetwork-filesharing/APKBUILD b/testing/kdenetwork-filesharing/APKBUILD
new file mode 100644
index 0000000000..81e8a16fe4
--- /dev/null
+++ b/testing/kdenetwork-filesharing/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdenetwork-filesharing
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/internet/"
+pkgdesc="Properties dialog plugin to share a directory with the local network"
+license="GPL-2.0-only OR GPL-3.0-only"
+depends="samba"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcompletion-dev kcoreaddons-dev ki18n-dev kio-dev kwidgetsaddons-dev kdoctools-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DSAMBA_INSTALL=OFF
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="67131174acd689def9ddfe783e2c5a335bbcadb5d1b3bfa6a62805d119acd8b633ac9120ccef39534842413d7aa494860188b59eed069cd64ff66c95c5777d75 kdenetwork-filesharing-19.04.2.tar.xz"