aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kdepim-addons
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-22 11:06:44 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-22 08:53:27 -0300
commit7f1cf8547cb838914c7db306ec28b6156e21102c (patch)
tree87e49b8523b7be774b5684938a8190eafe122661 /testing/kdepim-addons
parent51b9d5bb29cf37b1b423346638270c2c5e2bc9be (diff)
downloadaports-7f1cf8547cb838914c7db306ec28b6156e21102c.tar.bz2
aports-7f1cf8547cb838914c7db306ec28b6156e21102c.tar.xz
testing/kdepim-addons: rebuild against kcalendarcore
Diffstat (limited to 'testing/kdepim-addons')
-rw-r--r--testing/kdepim-addons/APKBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/testing/kdepim-addons/APKBUILD b/testing/kdepim-addons/APKBUILD
index 3c9c6d1706..4a2c277446 100644
--- a/testing/kdepim-addons/APKBUILD
+++ b/testing/kdepim-addons/APKBUILD
@@ -2,19 +2,26 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdepim-addons
pkgver=19.08.2
-pkgrel=0
+pkgrel=1
arch="all !ppc64le !s390x" # Limited by kdepim-addons -> kmailtransport -> libkgapi -> qt5-qtwebengine
url="https://kontact.kde.org/"
pkgdesc="Addons for KDE PIM applications"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtwebengine-dev ki18n-dev kconfig-dev kdbusaddons-dev akonadi-notes-dev kxmlgui-dev kdeclarative-dev syntax-highlighting-dev kio-dev kiconthemes-dev kparts-dev prison-dev kholidays-dev kcalcore-dev kcalutils-dev mailcommon-dev grantlee-dev messagelib-dev libkleo-dev grantleetheme-dev pimcommon-dev libkdepim-dev incidenceeditor-dev akonadi-dev akonadi-calendar-dev libgravatar-dev kpimtextedit-dev kidentitymanagement-dev kimap-dev libksieve-dev ktnef-dev kmailtransport-dev kcontacts-dev akonadi-contacts-dev mailimporter-dev gpgme-dev discount-dev kpkpass-dev kitinerary-dev akonadi-import-wizard-dev kontactinterface-dev"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtwebengine-dev ki18n-dev kconfig-dev kdbusaddons-dev akonadi-notes-dev kxmlgui-dev kdeclarative-dev syntax-highlighting-dev kio-dev kiconthemes-dev kparts-dev prison-dev kholidays-dev kcalendarcore-dev kcalutils-dev mailcommon-dev grantlee-dev messagelib-dev libkleo-dev grantleetheme-dev pimcommon-dev libkdepim-dev incidenceeditor-dev akonadi-dev akonadi-calendar-dev libgravatar-dev kpimtextedit-dev kidentitymanagement-dev kimap-dev libksieve-dev ktnef-dev kmailtransport-dev kcontacts-dev akonadi-contacts-dev mailimporter-dev gpgme-dev discount-dev kpkpass-dev kitinerary-dev akonadi-import-wizard-dev kontactinterface-dev"
checkdepends="xvfb-runi drkonqi"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/kdepim-addons-$pkgver.tar.xz"
subpackages="$pkgname-lang"
options="!check" # Require OpenGL and running dbus
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -23,11 +30,12 @@ build() {
}
check() {
- #
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}