aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kea-hook-runscript/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-12-07 11:23:21 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-12-07 11:24:51 +0100
commitdf4f072457340a5f06f266a0022a1f78223ff881 (patch)
treee736a1b4f9e5d3a91c5d87e93623acc0a8a18dc7 /testing/kea-hook-runscript/APKBUILD
parent71ae4feb6958b8fc3369d40169f03aa97c12c82a (diff)
downloadaports-df4f072457340a5f06f266a0022a1f78223ff881.tar.bz2
aports-df4f072457340a5f06f266a0022a1f78223ff881.tar.xz
testing/kea-hook-runscript: improve abuild
Diffstat (limited to 'testing/kea-hook-runscript/APKBUILD')
-rw-r--r--testing/kea-hook-runscript/APKBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/testing/kea-hook-runscript/APKBUILD b/testing/kea-hook-runscript/APKBUILD
index 352ea10abe..820580c69c 100644
--- a/testing/kea-hook-runscript/APKBUILD
+++ b/testing/kea-hook-runscript/APKBUILD
@@ -1,5 +1,4 @@
# Maintainer: Steve HOLWEG <skytep@gmail.com>
-
pkgname=kea-hook-runscript
pkgver=1.1.0
pkgrel=1
@@ -8,24 +7,16 @@ arch="all"
url="https://github.com/zorun/kea-hook-runscript"
license="MPL2"
depends="kea>=1.4.0"
-makedepends="kea-dev kea-utils boost-dev"
-install=""
-subpackages=""
+makedepends="boost-dev kea-dev kea-utils"
source="$pkgname-$pkgver.tar.gz::https://github.com/zorun/$pkgname/archive/v$pkgver.tar.gz"
-options="!check" # Library and makefile provide no tests
+options="!check" # Library and makefile provide no tests
build() {
- cd "$builddir"
-
make
}
package() {
- cd "$builddir"
-
- mkdir -p "${pkgdir}/usr/lib/hooks/"
-
- install -Dm755 "kea-hook-runscript.so" "${pkgdir}/usr/lib/hooks/kea-hook-runscript.so"
+ install -Dm755 kea-hook-runscript.so "$pkgdir"/usr/lib/hooks/kea-hook-runscript.so
}
sha512sums="b3b1c8ede6758b596fc03394bbd609aa7971d6b3bd267e2b5dda9c04ff6e9aa048de3d44e93ad287d70320784f1fcd101c03a9e8d12569403540fb49c32eda04 kea-hook-runscript-1.1.0.tar.gz"