aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kemoticons
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 07:41:54 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 12:05:35 +0000
commit6f252a7ffdd0ab3bba44673017123f0120047f3d (patch)
tree26462612c7c903a0d647ed967176cc6a5796b4b0 /testing/kemoticons
parent5a48202eedc1e42a053d3a179340917997ae0968 (diff)
downloadaports-6f252a7ffdd0ab3bba44673017123f0120047f3d.tar.bz2
aports-6f252a7ffdd0ab3bba44673017123f0120047f3d.tar.xz
testing/kemoticons: use xvfb-run to run testsuite
Closes GH-8389
Diffstat (limited to 'testing/kemoticons')
-rw-r--r--testing/kemoticons/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/testing/kemoticons/APKBUILD b/testing/kemoticons/APKBUILD
index abfa4d4b44..9550e502fe 100644
--- a/testing/kemoticons/APKBUILD
+++ b/testing/kemoticons/APKBUILD
@@ -6,12 +6,12 @@ pkgrel=0
pkgdesc="Support for emoticons and emoticons themes"
arch="all"
url="https://community.kde.org/Frameworks"
-license="LGPL-2.1+ AND (LGPL-2.1-only OR LGPL-3.0-only)"
+license="LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="karchive-dev kconfig-dev kservice-dev kcoreaddons-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # Fails due to requiring running X11
build() {
cmake \
@@ -23,10 +23,9 @@ build() {
}
check() {
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
-
package() {
DESTDIR="$pkgdir" make install
}