aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kemoticons
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-31 15:47:06 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-01 17:41:57 +0000
commit5bd593bdd5295dd529b99323ece93cadc689aed3 (patch)
tree150cc15ad5aca0edea88560ae0c51a7eb61d9285 /testing/kemoticons
parentd678bdd67ed4b18bbcfd90562cabf33474a89f7c (diff)
downloadaports-5bd593bdd5295dd529b99323ece93cadc689aed3.tar.bz2
aports-5bd593bdd5295dd529b99323ece93cadc689aed3.tar.xz
testing/kemoticons: new aport
Closes GH-8328
Diffstat (limited to 'testing/kemoticons')
-rw-r--r--testing/kemoticons/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/kemoticons/APKBUILD b/testing/kemoticons/APKBUILD
new file mode 100644
index 0000000000..abfa4d4b44
--- /dev/null
+++ b/testing/kemoticons/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kemoticons
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Support for emoticons and emoticons themes"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1+ AND (LGPL-2.1-only OR LGPL-3.0-only)"
+depends_dev="karchive-dev kconfig-dev kservice-dev kcoreaddons-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # Fails due to requiring running X11
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="2fb641e05cffa31e7d2d9d2a0110ade0f1fdee7fc3f23924505c874d76db24999b041b7df4cb62ecb455081457e013a7ee906479acd35dfe283843c1d269ecc2 kemoticons-5.58.0.tar.xz"