aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kiconthemes
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-31 15:51:30 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-01 17:41:58 +0000
commit54b980fb895cad00390f4f541b076a9021c0b8ba (patch)
tree463e3ddb54d9655f638ce11d40e0b1fbf73c09fe /testing/kiconthemes
parent23c681a6d5e4f0a98799b6244bd1c84157bbb53c (diff)
downloadaports-54b980fb895cad00390f4f541b076a9021c0b8ba.tar.bz2
aports-54b980fb895cad00390f4f541b076a9021c0b8ba.tar.xz
testing/kiconthemes: new aport
Closes GH-8328
Diffstat (limited to 'testing/kiconthemes')
-rw-r--r--testing/kiconthemes/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/kiconthemes/APKBUILD b/testing/kiconthemes/APKBUILD
new file mode 100644
index 0000000000..c334c54dfa
--- /dev/null
+++ b/testing/kiconthemes/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kiconthemes
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Support for icon themes"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only"
+depends_dev="qt5-qtsvg-dev karchive-dev ki18n-dev kcoreaddons-dev kconfigwidgets-dev kwidgetsaddons-dev kitemviews-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+options="!check" # Fails due to requiring running X11
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="4ccaa35b81daef5e63ba43ce8baa5097282aa790cb8596ced8f8c23570813433ac497090fee257f764363150a487a433af68cf6e065d90c2163acfbea1e36bab kiconthemes-5.58.0.tar.xz"