aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kimchi
diff options
context:
space:
mode:
authorAndré Bierwolf <a.b.bierwolf@gmail.com>2017-08-17 07:35:48 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-08-17 08:15:41 +0000
commite0a6665f8b44d4478681c3f31012f0a0d5f920b7 (patch)
tree37034b129b3995665c9edf322792335df1241165 /testing/kimchi
parent201504f7f90814d1fd2b0036f35d5d3a2f1437d9 (diff)
downloadaports-e0a6665f8b44d4478681c3f31012f0a0d5f920b7.tar.bz2
aports-e0a6665f8b44d4478681c3f31012f0a0d5f920b7.tar.xz
Upgraded to version 2.5.0 and added a patch to make novnc console work
Diffstat (limited to 'testing/kimchi')
-rw-r--r--testing/kimchi/APKBUILD8
-rw-r--r--testing/kimchi/alpine-specific-kimchi.api.patch20
2 files changed, 26 insertions, 2 deletions
diff --git a/testing/kimchi/APKBUILD b/testing/kimchi/APKBUILD
index db8c209c03..b7d87f189c 100644
--- a/testing/kimchi/APKBUILD
+++ b/testing/kimchi/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=kimchi
-pkgver=2.4.0
+pkgver=2.5.0
pkgrel=0
pkgdesc="An HTML5 management interface for KVM"
url="https://github.com/kimchi-project/kimchi"
@@ -21,6 +21,7 @@ depends="
py-websockify
py2-pillow
qemu
+ qemu-img
py2-configobj
py2-six
py2-paramiko
@@ -34,6 +35,7 @@ depends="
spice-html5
websockify
py-numpy
+ novnc
"
makedepends="
automake
@@ -58,6 +60,7 @@ makedepends="
options="!check"
subpackages="$pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz
+ alpine-specific-kimchi.api.patch
systemd-substitution-with-openrc.patch"
builddir="$srcdir/$pkgname-$pkgver"
@@ -77,5 +80,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="d51fa52b420cc6b775225e410fa7f222700d351cccca8eb0fda492bf4973c1808f3bf13d5a01a825b2163124c8925ffba810ec80f0110c9978e4566bdc9b2733 kimchi-2.4.0.tar.gz
+sha512sums="bcf20590d60cf3c82e34cb32e3a65aa7c87426eb721af7098234c5e1ff6fd1766b44d45d4ff4283e7122f370914e58b67fed1ba7b97df0cc26e614a4b66eb2d1 kimchi-2.5.0.tar.gz
+ac0cb9517161262109d754a469507dbb81607f52443514b227c3088ea11271ee465f017d6076519b820bc4021fd69eca3484059553072062f18334c69c5fb36a alpine-specific-kimchi.api.patch
a78c51237233b629c84106cfcdc8398a030889dd8bc641630a8c4e05fdad8d32a9b457c36188e1752a1277ef884437c1765c897bc2a33ca87c07e3bafdfdd5bf systemd-substitution-with-openrc.patch"
diff --git a/testing/kimchi/alpine-specific-kimchi.api.patch b/testing/kimchi/alpine-specific-kimchi.api.patch
new file mode 100644
index 0000000000..e092f46c70
--- /dev/null
+++ b/testing/kimchi/alpine-specific-kimchi.api.patch
@@ -0,0 +1,20 @@
+--- a/ui/js/src/kimchi.api.js
++++ b/ui/js/src/kimchi.api.js
+@@ -324,7 +324,7 @@
+ url += server_root;
+ url += "/plugins/kimchi/serial/html/serial.html";
+ url += "?port=" + proxy_port;
+- url += "&path=" + server_root + "/websockify";
++ url += "&path=" + server_root + "websockify";
+ url += "?token=" + wok.urlSafeB64Encode(vm+'-console').replace(/=*$/g, "");
+ url += '&encrypt=1';
+ window.open(url);
+@@ -348,7 +348,7 @@
+ url += server_root;
+ url += "/plugins/kimchi/novnc/vnc_auto.html";
+ url += "?port=" + proxy_port;
+- url += "&path=" + server_root + "/websockify";
++ url += "&path=" + server_root + "websockify";
+ /*
+ * From python documentation base64.urlsafe_b64encode(s)
+ * substitutes - instead of + and _ instead of / in the