aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kimchi
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 15:57:07 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 15:57:11 +0000
commitcab940a0509aafae5adbeb92a29d27b93b0fa77f (patch)
tree5ee8e9a5d685f6f2ce373d9677e36ec1bdead9ed /testing/kimchi
parentee9f4c8b52ad4678f82c27c364fcf9e52d620cd5 (diff)
downloadaports-cab940a0509aafae5adbeb92a29d27b93b0fa77f.tar.bz2
aports-cab940a0509aafae5adbeb92a29d27b93b0fa77f.tar.xz
testing/kimchi: added further dependencies
Diffstat (limited to 'testing/kimchi')
-rw-r--r--testing/kimchi/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/testing/kimchi/APKBUILD b/testing/kimchi/APKBUILD
index ef065aa3de..3e5fae061a 100644
--- a/testing/kimchi/APKBUILD
+++ b/testing/kimchi/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=kimchi
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="An HTML5 management interface for KVM "
url="https://kimchi-project.github.io"
arch="noarch"
@@ -10,11 +10,12 @@ license="APACHE LGPL2.1"
depends="python2 py-ipaddr py2-m2crypto py2-simplejson py-psutil
py-imaging py2-libvirt py-cheetah py-ethtool py2-lxml py-websockify
py2-pillow qemu py2-configobj py2-six py2-paramiko py2-magic libvirt-daemon
-wok gingerbase py2-netaddr py2-libuser"
+wok gingerbase py2-netaddr py2-libuser
+util-linux spice-html5"
makedepends="automake autoconf libtool gettext-dev
python2-dev py-setuptools pyflakes libxslt py2-pip
py-pep8 py2-mock py-cherrypy pytest py2-requests
-grep bash bc"
+grep bash bc spice-html5"
subpackages="$pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -25,7 +26,8 @@ build() {
./configure \
--prefix=/usr \
--sysconfdir=/etc \
- --localstatedir=/var
+ --localstatedir=/var \
+ --with-spice-html5
make -j1 || return 1
}