aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kimchi
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-21 10:50:48 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-21 10:52:03 +0000
commit8518d438784e88f6207837d21fd22c8de3840bf6 (patch)
treec330d9d4a2345b55e7130582d1d716d3872a8cea /testing/kimchi
parentc3ae6deca00216b272ab7ea0e26cecb452b9d9c7 (diff)
downloadaports-8518d438784e88f6207837d21fd22c8de3840bf6.tar.bz2
aports-8518d438784e88f6207837d21fd22c8de3840bf6.tar.xz
testing/kimchi: use rc-service to verify libvirtd status, rather than systemctl
Diffstat (limited to 'testing/kimchi')
-rw-r--r--testing/kimchi/APKBUILD14
-rw-r--r--testing/kimchi/systemd-substitution-with-openrc.patch14
2 files changed, 23 insertions, 5 deletions
diff --git a/testing/kimchi/APKBUILD b/testing/kimchi/APKBUILD
index 88472a1d38..1468cb928f 100644
--- a/testing/kimchi/APKBUILD
+++ b/testing/kimchi/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=kimchi
pkgver=2.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="An HTML5 management interface for KVM "
url="https://kimchi-project.github.io"
arch="noarch"
@@ -17,7 +17,8 @@ python2-dev py-setuptools pyflakes libxslt py2-pip
py-pep8 py2-mock py-cherrypy pytest py2-requests
grep bash bc spice-html5"
subpackages="$pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz
+systemd-substitution-with-openrc.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -36,6 +37,9 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="3312e6158c5bde8be3e499b6b4488751 kimchi-2.3.1.tar.gz"
-sha256sums="81da6381480d2a69eb6cf073b1e0f7c9288d13c2f34f90dabf3568ce089d15d0 kimchi-2.3.1.tar.gz"
-sha512sums="2db03e66277df6d7d66dae25e6663e32eba791dca563d7bef02d394f8352cca2dbd1a904c76f0ae0b3a1ca2593c7fcb99be3877f658a22b54cd79e2b332d8b74 kimchi-2.3.1.tar.gz"
+md5sums="3312e6158c5bde8be3e499b6b4488751 kimchi-2.3.1.tar.gz
+c46ad325d11ed135a3bea6ddcb688faa systemd-substitution-with-openrc.patch"
+sha256sums="81da6381480d2a69eb6cf073b1e0f7c9288d13c2f34f90dabf3568ce089d15d0 kimchi-2.3.1.tar.gz
+afaa9128c4d2f21e717ef1c059eb7a14cd5802ac55c4d7fa696ecb2260043755 systemd-substitution-with-openrc.patch"
+sha512sums="2db03e66277df6d7d66dae25e6663e32eba791dca563d7bef02d394f8352cca2dbd1a904c76f0ae0b3a1ca2593c7fcb99be3877f658a22b54cd79e2b332d8b74 kimchi-2.3.1.tar.gz
+b4ec58de87d26e8f342c5f78818a96a3c7cbb8de979a7e9fa9b3ececbc98775d435e065dc41023968efa919f3ed1636c4409420d1f55f4ddb94dd4b9a573399f systemd-substitution-with-openrc.patch"
diff --git a/testing/kimchi/systemd-substitution-with-openrc.patch b/testing/kimchi/systemd-substitution-with-openrc.patch
new file mode 100644
index 0000000000..0ca2ff19a9
--- /dev/null
+++ b/testing/kimchi/systemd-substitution-with-openrc.patch
@@ -0,0 +1,14 @@
+diff --git a/utils.py b/utils.py
+index 1e2c951..459c76f 100644
+--- a/utils.py
++++ b/utils.py
+@@ -263,6 +263,7 @@ def is_libvirtd_up():
+ """
+ Checks if libvirtd.service is up.
+ """
+- cmd = ['systemctl', 'is-active', 'libvirtd.service']
++ cmd = ['rc-service', 'is-active', 'libvirtd.service']
++ cmd = ['rc-service', 'libvirtd', 'status']
+ output, error, rc = run_command(cmd, silent=True)
+- return True if output == 'active\n' else False
++ return True if "started" in output else False