aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kitty
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-14 23:17:36 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-15 01:27:35 -0300
commitdce0818b7e48da7bc0744430a529f3f2549da39f (patch)
treebd29057eb23f88fb06fd96671625f652c8affe8f /testing/kitty
parent1c7c96cae033c90973abef89b3b8acfbb580a8b1 (diff)
downloadaports-dce0818b7e48da7bc0744430a529f3f2549da39f.tar.bz2
aports-dce0818b7e48da7bc0744430a529f3f2549da39f.tar.xz
testing/kitty: use sphinx-build-3
Diffstat (limited to 'testing/kitty')
-rw-r--r--testing/kitty/APKBUILD11
-rw-r--r--testing/kitty/py3.patch14
2 files changed, 21 insertions, 4 deletions
diff --git a/testing/kitty/APKBUILD b/testing/kitty/APKBUILD
index a0183629b6..cc7b5772d7 100644
--- a/testing/kitty/APKBUILD
+++ b/testing/kitty/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=kitty
pkgver=0.14.4
-pkgrel=0
+pkgrel=1
pkgdesc="A modern, hackable, featureful, OpenGL based terminal emulator"
url="https://sw.kovidgoyal.net/kitty/"
arch="all"
@@ -18,10 +18,12 @@ depends="py3-pygments imagemagick ncurses"
makedepends="py3-setuptools harfbuzz-dev zlib-dev libpng-dev freetype-dev
fontconfig-dev mesa-dev python3-dev dbus-dev libxi-dev
libxkbcommon-dev libxrandr-dev libxinerama-dev libxcursor-dev
- wayland-protocols wayland-dev py-sphinx libcanberra-dev"
+ wayland-protocols wayland-dev py3-sphinx libcanberra-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/kovidgoyal/kitty/archive/v$pkgver.tar.gz
- fix-ppc64le-build-ioctl-with-musl.patch"
+ fix-ppc64le-build-ioctl-with-musl.patch
+ py3.patch
+ "
# Remove once sphinx-build gets py-attrs dependency
makedepends="$makedepends py3-attrs"
@@ -39,4 +41,5 @@ package() {
}
sha512sums="fb51b8182a7279aab4740f0d5cea5c1da4c6ac82845fceca221f7b9630036e1059c2c946f16815eea004e4962bf6974f3c77bfb7c90039e09852f5f36173b5c0 kitty-0.14.4.tar.gz
-330f56f5fd60607c57f4f2cffdf33768b3af9e4c3e271a60a05cc3c653d70f7402af91ba0cdfe0257c8b4779884a6440eb52496078bce11799aaa1829ced9245 fix-ppc64le-build-ioctl-with-musl.patch"
+330f56f5fd60607c57f4f2cffdf33768b3af9e4c3e271a60a05cc3c653d70f7402af91ba0cdfe0257c8b4779884a6440eb52496078bce11799aaa1829ced9245 fix-ppc64le-build-ioctl-with-musl.patch
+e1efe3353721143bef6e198466e84ba5888c6c5f336807c47af4453a2b063d248d3893143dff1792beb71b67bb155dcf5c0bb30d1c265b2fca24e35c6e34a1e2 py3.patch"
diff --git a/testing/kitty/py3.patch b/testing/kitty/py3.patch
new file mode 100644
index 0000000000..0634882156
--- /dev/null
+++ b/testing/kitty/py3.patch
@@ -0,0 +1,14 @@
+diff --git a/docs/Makefile b/docs/Makefile
+index 2e07b01..4f77cc3 100644
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -3,7 +3,7 @@
+
+ # You can set these variables from the command line.
+ SPHINXOPTS = -j auto -T $(FAIL_WARN)
+-SPHINXBUILD = sphinx-build
++SPHINXBUILD = sphinx-build-3
+ SPHINXPROJ = kitty
+ SOURCEDIR = .
+ BUILDDIR = _build
+