aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kitty
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-30 15:52:57 -0300
committerprspkt <prspkt@protonmail.com>2019-05-30 23:05:06 +0300
commit1ae285e68fa1b42768939be712287a787f921c7a (patch)
tree92307743d7a595d1f58ace1f1c7f9414acb8c0e4 /testing/kitty
parent5602546843ce2270fd5e594dcf69568da321a128 (diff)
downloadaports-1ae285e68fa1b42768939be712287a787f921c7a.tar.bz2
aports-1ae285e68fa1b42768939be712287a787f921c7a.tar.xz
testing/kitty: modernize, fix license
Diffstat (limited to 'testing/kitty')
-rw-r--r--testing/kitty/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/testing/kitty/APKBUILD b/testing/kitty/APKBUILD
index b7856afb48..bcf5fbb84e 100644
--- a/testing/kitty/APKBUILD
+++ b/testing/kitty/APKBUILD
@@ -2,40 +2,36 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=kitty
pkgver=0.14.1
-pkgrel=0
+pkgrel=1
pkgdesc="A modern, hackable, featureful, OpenGL based terminal emulator"
url="https://sw.kovidgoyal.net/kitty/"
arch="all"
-license="GPL-3.0"
+license="GPL-3.0-only"
#some test fails, disabled for now:
-#ERROR: test_box_drawing
+#ERROR: test_box_drawing
#ERROR: test_emoji_presentation
-#ERROR: test_font_rendering
+#ERROR: test_font_rendering
#ERROR: test_shaping
-#ERROR: test_sprite_map
+#ERROR: test_sprite_map
options="!check"
depends="py3-pygments imagemagick ncurses"
-makedepends="py3-setuptools harfbuzz-dev zlib-dev libpng-dev freetype-dev
+makedepends="py3-setuptools harfbuzz-dev zlib-dev libpng-dev freetype-dev
fontconfig-dev mesa-dev python3-dev dbus-dev libxi-dev
libxkbcommon-dev libxrandr-dev libxinerama-dev libxcursor-dev
wayland-protocols wayland-dev py-sphinx"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/kovidgoyal/$pkgname/archive/v$pkgver.tar.gz
fix-ppc64le-build-ioctl-with-musl.patch"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py linux-package
}
check() {
- cd "$builddir"
python3 setup.py test
}
package() {
- cd "$builddir"
python3 setup.py linux-package --prefix ${pkgdir}/usr
}