aboutsummaryrefslogtreecommitdiffstats
path: root/testing/knotifications
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-28 22:17:13 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-29 18:58:33 +0000
commitfbd5d5a83f201f32147c446355999d8598028abb (patch)
treed0bc368a64afa2566d6161bed0590df9f7ac89ea /testing/knotifications
parent39afe3b2bb09e37cf96bba85ebdb30eb49b2c28e (diff)
downloadaports-fbd5d5a83f201f32147c446355999d8598028abb.tar.bz2
aports-fbd5d5a83f201f32147c446355999d8598028abb.tar.xz
testing/knotifications: new aport
Closes GH-8204
Diffstat (limited to 'testing/knotifications')
-rw-r--r--testing/knotifications/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/knotifications/APKBUILD b/testing/knotifications/APKBUILD
new file mode 100644
index 0000000000..07c271d14c
--- /dev/null
+++ b/testing/knotifications/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=knotifications
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Abstraction for system notifications"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends_dev="qt5-qtbase-dev qt5-qtspeech-dev qt5-qtx11extras-dev kwindowsystem-dev kconfig-dev kcodecs-dev kcoreaddons-dev phonon-dev"
+makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+options="!check" # Fails due to requiring running dbus-daemon
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="40614ca155fe9839e511a3416ee85b233e0b8ce9a3f3ee182f959332d61dcd323267f19dbb71f73fed334f5de22a8efa5bfaea5ca115c21f33efcdd08567ae2d knotifications-5.58.0.tar.xz"