aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kontact
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-19 17:01:10 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-20 08:27:45 -0300
commit8dcc7a623e0f5d027bbb9319a23053b210df8b40 (patch)
tree427d7ed7ab88304d348c572e97383cd530ae56f5 /testing/kontact
parent02e3b4fe5d1c17eeb866ea50cdd0a9a822be09ba (diff)
downloadaports-8dcc7a623e0f5d027bbb9319a23053b210df8b40.tar.bz2
aports-8dcc7a623e0f5d027bbb9319a23053b210df8b40.tar.xz
testing/kontact: new aport
Diffstat (limited to 'testing/kontact')
-rw-r--r--testing/kontact/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/kontact/APKBUILD b/testing/kontact/APKBUILD
new file mode 100644
index 0000000000..8c2fe5c1d4
--- /dev/null
+++ b/testing/kontact/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kontact
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="https://kontact.kde.org/"
+pkgdesc="Container application to unify several major PIM applications within one application"
+license="GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtwebengine-dev kdbusaddons-dev
+ kdoctools-dev kcmutils-dev kcrash-dev kwindowsystem-dev kiconthemes-dev
+ kpimtextedit-dev akonadi-dev libkdepim-dev grantleetheme-dev kontactinterface-dev
+ kdepim-apps-libs-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="25574deba5ec9faf6483eb62f71685e45148cee1450947f2305cc94e853add1a5255956098c8e803908af80dd848a24b629b3a6834f0728044dfdda29f016699 kontact-19.04.2.tar.xz"