aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kphotoalbum
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-06 14:28:46 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-06 15:49:08 -0300
commit3d9f17ea5136dea40b014fc47f6fd4e2d1556065 (patch)
tree09142220807f15cd7b8c92b99774c03e83fbeb7e /testing/kphotoalbum
parentfe8c6efb7f32a9cc90e6a34f4bac9facc6239061 (diff)
downloadaports-3d9f17ea5136dea40b014fc47f6fd4e2d1556065.tar.bz2
aports-3d9f17ea5136dea40b014fc47f6fd4e2d1556065.tar.xz
testing/kphotoalbum: new aport
Diffstat (limited to 'testing/kphotoalbum')
-rw-r--r--testing/kphotoalbum/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/kphotoalbum/APKBUILD b/testing/kphotoalbum/APKBUILD
new file mode 100644
index 0000000000..b9152ae10e
--- /dev/null
+++ b/testing/kphotoalbum/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname="kphotoalbum"
+pkgver="5.6.1"
+pkgrel=0
+pkgdesc="KDE Photo Album, picture collection manager"
+url="https://kphotoalbum.org"
+# ppc64le and s390x blocked by marble-dev
+arch="all !ppc64le !s390x"
+license="GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev phonon-dev karchive-dev kcompletion-dev kconfig-dev kcoreaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev kjobwidgets-dev kio-dev ktextwidgets-dev kxmlgui-dev kwidgetsaddons-dev jpeg-dev exiv2-dev libkipi-dev purpose-dev libkdcraw-dev marble-dev libkgeomap-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.kde.org/stable/kphotoalbum/$pkgver/kphotoalbum-$pkgver.tar.xz"
+
+build() {
+ cmake -B "$builddir"/build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make -C build
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C build install
+}
+
+sha512sums="fa1f4d566cd99e8c434b6e1fe28d8910b3b9c6aa05947ffbfa1b2b8efdab76f243f4b12883586e0c6692bfe54763a285374e16f3ceb23051619fe9b84cd58ea7 kphotoalbum-5.6.1.tar.xz"