aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kplotting
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-22 00:49:05 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-28 17:14:48 +0000
commit70f7ae85cec5b4b53ca43a601c117d85265cce90 (patch)
treef3c3131e4d4a818cecad777e0b96a5ba6ba16ddb /testing/kplotting
parentf7a76f05ea5d57e43a107375c39c230aa5ebc80a (diff)
downloadaports-70f7ae85cec5b4b53ca43a601c117d85265cce90.tar.bz2
aports-70f7ae85cec5b4b53ca43a601c117d85265cce90.tar.xz
testing/kplotting: new aport
Closes GH-7992
Diffstat (limited to 'testing/kplotting')
-rw-r--r--testing/kplotting/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/kplotting/APKBUILD b/testing/kplotting/APKBUILD
new file mode 100644
index 0000000000..d430772a88
--- /dev/null
+++ b/testing/kplotting/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kplotting
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Lightweight plotting framework"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-or-later"
+depends_dev="qt5-qtbase-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # Fails due to requiring running X11
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="5c447f24d7dae28b75da8c2102d03f47757094dc41c79d21c474e0a19fb0c3ff96eda308b761bf8ca2f9a242cc611aaf496c3b67ee1ee587d64447413717f215 kplotting-5.58.0.tar.xz"