aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kubernetes
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 00:33:06 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-27 06:37:18 +0000
commit9b2313f227186af07380ffb661f27f936be0498a (patch)
tree06cd5006783a2243aa5a7826eece0740985af15c /testing/kubernetes
parent82cb81d5040069dc42911e35dd66fffb01d1bb85 (diff)
downloadaports-9b2313f227186af07380ffb661f27f936be0498a.tar.bz2
aports-9b2313f227186af07380ffb661f27f936be0498a.tar.xz
testing/kubernetes: modernize
Diffstat (limited to 'testing/kubernetes')
-rw-r--r--testing/kubernetes/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/testing/kubernetes/APKBUILD b/testing/kubernetes/APKBUILD
index b50cee9d5a..a35d985b84 100644
--- a/testing/kubernetes/APKBUILD
+++ b/testing/kubernetes/APKBUILD
@@ -9,9 +9,9 @@ pkgdesc="Container Cluster Manager for Docker"
url="https://kubernetes.io/"
arch="x86_64"
license="Apache-2.0"
-options="!check"
+options="!check" # Tests hang
depends="bash"
-makedepends="bash coreutils findutils go linux-headers rsync grep"
+makedepends="coreutils findutils go linux-headers rsync grep"
source="$pkgname-$pkgver.tar.gz::https://github.com/kubernetes/kubernetes/archive/v$pkgver.tar.gz
ensure-cgo-usage.patch
make-e2e_node-run-over-distro-bins.patch
@@ -21,12 +21,10 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/kubernetes/kubernetes/archiv
"
build() {
- cd "$builddir"
KUBE_VERBOSE=2 make -j1
}
package() {
- cd "$builddir"
local binaries="hyperkube
kube-apiserver
kube-controller-manager