aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kwallet-pam
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-22 22:24:20 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-22 17:26:32 -0300
commite59eac495a999861cf71f15eceb1ad53461ff941 (patch)
treeb570cdce42d908e846a555bbf76ea97328e9b457 /testing/kwallet-pam
parent7b2e7b0b4e5c232ebe378054980147c9802d8ef3 (diff)
downloadaports-e59eac495a999861cf71f15eceb1ad53461ff941.tar.bz2
aports-e59eac495a999861cf71f15eceb1ad53461ff941.tar.xz
testing/kwallet-pam: new aport
Diffstat (limited to 'testing/kwallet-pam')
-rw-r--r--testing/kwallet-pam/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/kwallet-pam/APKBUILD b/testing/kwallet-pam/APKBUILD
new file mode 100644
index 0000000000..104f0f86b5
--- /dev/null
+++ b/testing/kwallet-pam/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kwallet-pam
+pkgver=5.16.1
+pkgrel=0
+pkgdesc="KWallet PAM integration"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="LGPL-2.1-or-later"
+makedepends="extra-cmake-modules linux-pam-dev libgcrypt-dev socat kwallet-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+options="!check" # No tests available
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="7faf70097673e221630d2ae0e0b998223349dbe0ba81e7a038e1c604af0fffe398b2b18d55112c040e0fa974d92699dcf163576b529e368af3db06e68783af6f kwallet-pam-5.16.1.tar.xz"