aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kyotocabinet
diff options
context:
space:
mode:
authorinnerspacepilot <innerspacepilot@gmx.com>2019-04-24 18:55:13 +0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-13 12:41:27 -0300
commit49ee314c783ea7d2fa3e390482ed02fba77335dd (patch)
treea3de3e83405510232d05ff460f5e8c363967b9de /testing/kyotocabinet
parentf51085e527166caf2c0fa5c5f27f6138c81cb668 (diff)
downloadaports-49ee314c783ea7d2fa3e390482ed02fba77335dd.tar.bz2
aports-49ee314c783ea7d2fa3e390482ed02fba77335dd.tar.xz
testing/kyotocabinet: new aport
Diffstat (limited to 'testing/kyotocabinet')
-rw-r--r--testing/kyotocabinet/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/kyotocabinet/APKBUILD b/testing/kyotocabinet/APKBUILD
new file mode 100644
index 0000000000..103f48b8a7
--- /dev/null
+++ b/testing/kyotocabinet/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Andrey L <innerspacepilot@gmx.com>
+# Maintainer: Andrey L <innerspacepilot@gmx.com>
+pkgname=kyotocabinet
+pkgver=1.2.77
+pkgrel=0
+pkgdesc="Kyoto Cabinet is a library of routines for managing a database."
+url="https://fallabs.com/kyotocabinet/"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="zlib-dev lzo-dev xz-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://fallabs.com/kyotocabinet/pkg/kyotocabinet-$pkgver.tar.gz"
+
+build() {
+ ./configure --prefix=/usr --enable-lzo --enable-lzma
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib/*.a
+}
+
+sha512sums="f38794c11faa3f4b64097a2e314307e1a6b75ddc495103647ebe52786a689336754496e7083697417ea90436e7fad681f16440975abec9ae917874aa25153e0f kyotocabinet-1.2.77.tar.gz"