aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lablgtk
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-25 10:06:32 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-25 10:06:32 +0000
commit15d5b4f01af7fc0d737cedc65bd695280b7fcebb (patch)
tree4f90d1ed2afcb623b1a9dc163ca44be23d2f1d41 /testing/lablgtk
parent2a7b628cdd730b516438e7fab516e84accd72167 (diff)
downloadaports-15d5b4f01af7fc0d737cedc65bd695280b7fcebb.tar.bz2
aports-15d5b4f01af7fc0d737cedc65bd695280b7fcebb.tar.xz
Revert "community/lablgtk: move from testing"
Diffstat (limited to 'testing/lablgtk')
-rw-r--r--testing/lablgtk/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/lablgtk/APKBUILD b/testing/lablgtk/APKBUILD
new file mode 100644
index 0000000000..d820aba609
--- /dev/null
+++ b/testing/lablgtk/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=lablgtk
+pkgver=2.18.5
+pkgrel=3
+pkgdesc="LablGtk - an OCaml interface to GTK+ 2.x"
+url="http://lablgtk.forge.ocamlcore.org/"
+# ocaml is not built for x86, armhf
+arch="x86_64"
+license="GPL"
+depends_dev="lablgtk gtk+-dev gtkspell-dev librsvg-dev gtksourceview2-dev"
+depends="ocaml-findlib camlp4 ocaml"
+makedepends="$depends $depends_dev"
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://forge.ocamlcore.org/frs/download.php/1627/lablgtk-$pkgver.tar.gz"
+builddir="$srcdir/lablgtk-$pkgver"
+
+options="!check"
+
+build() {
+ cd "$builddir"
+
+ ./configure --prefix=/usr
+ make world
+ make opt
+ make doc
+}
+
+doc() {
+ pkgdesc="$pkgdesc (documentation)"
+
+ local docdir="$subpkgdir"/usr/share/doc/$pkgname/
+ mkdir -p "$docdir"
+ cp -r "$builddir"/doc/html/* "$docdir"/
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib/ocaml/ld.conf
+}
+
+md5sums="43eb7062439f7ddd0d8ad96c3e3b87dd lablgtk-2.18.5.tar.gz"
+sha256sums="2bf251db21c077fdd26c035ea03edd8fe609187f908e520e87a8ffdd9c36d233 lablgtk-2.18.5.tar.gz"
+sha512sums="7b6ba1a4dfa82cc3bbc502082ff4fccc23cc06ee4f30d01a2e423f3f99e945a4befe450d230b5aa19c5b810e9f46f2838655099d49da2db7c8a2e52eac213024 lablgtk-2.18.5.tar.gz"