aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lablgtk
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-01-28 01:12:09 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-28 01:13:24 +0100
commit92b2c2a8bf28a68173cb76c128d808e6149cb62a (patch)
treec2303b45aa5385352eb35484a2a00b4ceff98286 /testing/lablgtk
parent1b0f39f310060bddec88b7b84cd3a3e8527a1cad (diff)
downloadaports-92b2c2a8bf28a68173cb76c128d808e6149cb62a.tar.bz2
aports-92b2c2a8bf28a68173cb76c128d808e6149cb62a.tar.xz
testing/lablgtk: disable on aarch64 (build failed)
... ocamlopt.opt -w s -c gutf8.ml + gcc -fPIC -Os -std=gnu99 -O2 -fno-strict-aliasing -fwrapv -Wall -D_FILE_OFFSET_BITS=64 -D_REENTRANT -fPIC -c -DG_DISABLE_ASSERT -DG_DISABLE_CAST_CHECKS -fno-unwind-tables -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/atk-1.0 -I/usr/include/librsvg-2.0 -I/usr/include/gtkspell-2.0 -I/usr/include/gtksourceview-2.0 -pthread -I/usr/include/libxml2 -imacros ml_domain.h -O -I'/usr/lib/ocaml' 'ml_gtkspell.c' + gcc -fPIC -Os -std=gnu99 -O2 -fno-strict-aliasing -fwrapv -Wall -D_FILE_OFFSET_BITS=64 -D_REENTRANT -fPIC -c -DG_DISABLE_ASSERT -DG_DISABLE_CAST_CHECKS -fno-unwind-tables -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/atk-1.0 -I/usr/include/librsvg-2.0 -I/usr/include/gtkspell-2.0 -I/usr/include/gtksourceview-2.0 -pthread -I/usr/include/libxml2 -imacros ml_domain.h -O -I'/usr/lib/ocaml' 'ml_rsvg.c' ocamlc.opt -w s-3+52 -warn-error A-52 -c gpointer.ml ocamlc.opt -w s-3+52 -warn-error A-52 -c gutf8.ml ocamlc.opt -w s-3+52 -warn-error A-52 -c gobject.mli File "gtkThInit.ml", line 27, characters 13-28: Error: Unbound module GtkThread make[1]: *** [Makefile:192: gtkThInit.cmo] Error 2
Diffstat (limited to 'testing/lablgtk')
-rw-r--r--testing/lablgtk/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/testing/lablgtk/APKBUILD b/testing/lablgtk/APKBUILD
index 4da685341e..a7584cb402 100644
--- a/testing/lablgtk/APKBUILD
+++ b/testing/lablgtk/APKBUILD
@@ -5,7 +5,8 @@ pkgver=2.18.5
pkgrel=1
pkgdesc="LablGtk - an OCaml interface to GTK+ 2.x"
url="http://lablgtk.forge.ocamlcore.org/"
-arch="all !x86 !armhf" # limited by ocaml abuild
+# ocaml is not built for x86, armhf
+arch="all !x86 !armhf !aarch64"
license="GPL"
depends_dev="lablgtk"
depends="ocaml-findlib camlp4 ocaml gtk+-dev gtkspell-dev librsvg-dev