aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ladspa/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-28 14:56:45 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-28 14:56:45 -0600
commit1b2f90dd881665dc65a6986c362816174c3d1312 (patch)
treeb57ee919a2ff095e2e61f828a1b42a375f273587 /testing/ladspa/APKBUILD
parente18597d6c7237d41eff54519b85efa12b913efee (diff)
downloadaports-1b2f90dd881665dc65a6986c362816174c3d1312.tar.bz2
aports-1b2f90dd881665dc65a6986c362816174c3d1312.tar.xz
testing/ladspa: modernise, add test suite
Diffstat (limited to 'testing/ladspa/APKBUILD')
-rw-r--r--testing/ladspa/APKBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/testing/ladspa/APKBUILD b/testing/ladspa/APKBUILD
index 583cde5a6a..ded8ec023f 100644
--- a/testing/ladspa/APKBUILD
+++ b/testing/ladspa/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=ladspa
pkgver=1.13
-pkgrel=0
+pkgrel=1
pkgdesc="Linux Audio Developer's Simple Plug-in API, examples and tools"
url="http://www.ladspa.org/"
arch="all"
@@ -18,28 +18,27 @@ source="https://github.com/OpenMandrivaAssociation/ladspa/raw/master/ladspa_sdk_
builddir="$srcdir/ladspa_sdk/src"
prepare() {
- default_prepare || return 1
- sed -i 's/mkdirhier/mkdir -p/' makefile || return 1
+ default_prepare
+ sed -i 's/mkdirhier/mkdir -p/' makefile
}
build() {
cd "$builddir"
- make targets || return 1
+ make targets
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
make INSTALL_PLUGINS_DIR="$pkgdir/usr/lib/ladspa/" \
INSTALL_INCLUDE_DIR="$pkgdir/usr/include/" \
- INSTALL_BINARY_DIR="$pkgdir/usr/bin/" install || return 1
+ INSTALL_BINARY_DIR="$pkgdir/usr/bin/" install
}
-md5sums="671be3e1021d0722cadc7fb27054628e ladspa_sdk_1.13.tgz
-d3a0f23f66cd685fe4af419c4f587273 fallback-ladspa-path.patch
-525a958f339d7526562785484b577d00 fix-memleak-in-plugin-scanning.patch"
-sha256sums="b5ed3f4f253a0f6c1b7a1f4b8cf62376ca9f51d999650dd822650c43852d306b ladspa_sdk_1.13.tgz
-4d066b10a10801bc87468ddc4fb1672b2fa9866bd5f3155c71c884296c6345d0 fallback-ladspa-path.patch
-d12f061d2701f0d12f97f750bb6df7c3a9915db5e35a00bd7d1a6342218bcb39 fix-memleak-in-plugin-scanning.patch"
sha512sums="a1dab807fda58e08869d3f519be5fa91c394690eb13006fbe7f20b332548e4676b32b01273f5695bf36c8da72190c07618662a76d50f991b3f05068ac2b346ef ladspa_sdk_1.13.tgz
00891ac5d1e3ca17cf7d99e7d894b50f9a7df8eea80cd791593cf637bf9f4f7e658d0124c69aa32bb90a14150737a38cb48552c7991f3f2b6674b3634440504a fallback-ladspa-path.patch
1a96b24a47c2c82f7c2f66e2ee711f0ecbed9b03260562b72ced1bd4c8f0e518d15fc7c15951b95b1999e3dae1723b855fd3431a9795279f8a88ad68900e48e7 fix-memleak-in-plugin-scanning.patch"